[pstricks] Inconsistent naming convention in \psDefBoxNodes

Donut E. Knot the.counterterrorist at yahoo.com
Wed Feb 5 04:52:07 CET 2014

Dear PSTricks maintainers,

Consider the following code first.


\foreach \i in {rt,r,rB,rb,b,lb,lB,l,lt,t,c,B}{%

\rput defines 12 options: {rt,r,rB,rb,b,lb,lB,l,lt,t,c,B} where the two-character options can be swapped, e.g., rt is the same as tr, bl is the same as lb, etc.

Now consider the code below.


\foreach \i in {tr,r,Br,br,b,bl,Bl,l,tl,t,c,B}{% some \rput options do not in \psDefBoxNodes

\psDefBoxNodes seems to attempt adopting  2-character options PQ format where
PQ is an intersection point of a horizontal line P and a vertical line Q. Also PQ cannot be swapped to QP.
The horizontal lines P are  t, C, B, and b while the vertical lines Q are l, and r.
In my opinion the vertical lines Q needs one more option which is m (middle).

So we will have 12 points:
	* tl (top left)
	* Cl (center left)
	* Bl (baseline left)
	* bl (bottom left)
	* tm (top middle)
	* Cm (center middle)
	* Bm (baseline middle)
	* bm (bottom middle)
	* tr (top right)
	* Cr (center right)
	* Br (baseline right)
	* br (bottom right)


The current implementation of \psDefBoxNodes defined  tC (for top middle), C (for center middle), BC (for baseline middle), bC (for base middle). They look illogical, inconsistent, and difficult to remember. 

If you don't mind please kindly to reconsider this issue and apply the same pattern as \rput to \psDefBoxNodes options such that we can use the options easily without looking up the pst-node documentation again and again. 

Thank you in advance.

best regards,

Code Mocker
(about me: http://tex.stackexchange.com/users/19356)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/pstricks/attachments/20140204/daf8e1df/attachment.html>

More information about the PSTricks mailing list