[pstricks] Error using pst-light3d.tex

John Culleton john at wexfordpress.com
Fri May 9 18:55:58 CEST 2008

On Friday 09 May 2008 09:05:54 am Herbert Voss wrote:
> John Culleton schrieb:
> >> $ tex cull.tex
> >> This is TeX, Version 3.141592 (Web2C 7.5.6)
> John,
> what TeX version do you have running?
> Herbert
> _______________________________________________
> PSTricks mailing list
> PSTricks at tug.org
> http://tug.org/mailman/listinfo/pstricks
> __________________________________________________
> D O T E A S Y - "Join the web hosting revolution!"
>              http://www.doteasy.com

I have tried texlive-2007, a new install of texlive-2007 
in /usr/share, and Slackware's version of tetex (but that lacks many 

I have grepped such files as pstricks.tex   
looking for the string addfam as found in the command
\pst at addfams 
but I cannot find where it is defined.  If I could identify where that 
command is defined (if it is indeed a command)  then perhaps I could 
update that file.  I tried commenting out that line but then xkeyval 
! xkeyval error: `LightThreeDXLength' undefined in families `'.

One thing I have not tried: installing miktex on my new Win xp 
partition.  If all else fails I will try that.  Or maybe debian. 

BTW if I eliminate everything except the two input statements at the 
top I still get the error message.  The call to \pst at addfams occurs 
in the pst-light3d.tex file and nowhere else that I can find.   

Also I haven't tried LaTeX yet, out of an aversion for that format. 
But any port in a storm I guess. 
John Culleton
Resources for every author and publisher:

More information about the PSTricks mailing list