[pstricks] Re: pst-eucl (integrating Metapost into Pstricks :-)

Maurice DIAMANTINI diam at ensta.fr
Mon Jun 25 10:59:28 CEST 2001


I answer to all because I think it could generate a more
general discution about integrating METAPOST INTO PSTRICKS.
(Excuse my bad english!)

> I would be very interested by the first impressions of the use of
> pst-eucl.

I've not use your package (no time for the moment)
but I've read the doc.

First of all, I think that the "pst-eucl" is more general that
just being able to do some scolar geometric figures.
It do some work that ***METAPOST*** do : some declarative
To be able to define point as intesection of to figure
could be very usefull for all the Pstricks user

I'd like it to be included in the core of Pstricks!
But if it is, all the command names have to be cleaned
to be more Pstricks complient.

About the commands names, there are two options:

- either pst-geom is consider an addon to Pstricks,
  so all commands should begin by \geo... to avoid conflicts
  The advantage is that you could arrange all letters that
  follow this prefix.
  Also as you provide many many commands, I think the first 
  letters following this prefix should indicate
  the purpose of each command :
  Defining nodes:
    \geoNodeLC{}    instead of \pstInterLC
    \geoNodeLL{}    instead of \pstInter
    \geoNodeCC{}    instead of \pstInterCC
    \geoNodeSymxxx{} instead of \pstInterCC
                \geoNodeSymOrt instead of \pstOrtSym)
    \geoNodeSymxxx{} instead of \pstInterCC
                \geoNodeSymOrt instead of \pstOrtSym)
    \geoNodezzz{} (for defining all kind of center (gravity...)
    \geoNodeCurv{} to put a node at some curviline abscice
                    on some curve
    \geoSegxxx{}    (for Segment)
    \geoTrixxx{}    (for Triangle)
    \geoCirxxx{}    (for Circle)
    \geoDistxxx{}   (all what defined a distance)
    \geoBoxxxx{}    (for all predifined boxes or point shapes)
- either pst-geom becommed part of Pstricks core, but all 
  names should be cleaned to be more pstricks complient. 
  One should easily distinging between commands that define
  some nodes and commands that put something to a node. 
  Also you provide many commands that do both : defining
  a node and put something: this should be considere as
  a facility to do two thing in a single step.

- also some command which do similar thing have different
  names : they should be replace by option
    \pstBissectBAC should be \geoBissectBAC
    \pstOutBisBAC  should be \geoBissectBAC[geoReverse=true]

    \pstArcOAB     should be \geoArcOAB
    \pstArcnOAB    should be \geoArcOAB[geoReverse=true]

- also some option name could be rename:
    - for the option that could be map to existing pstricks 
      option : use them
    - for other, they could be rename 
       PosAngle --> geoLabelAngle
       PosDist  --> geoLabelSep
    - also what does mean the boolean "CodeFig" option???
        shouldn't it be rename something like
        drawGuideLines (ligne de rappel en français :-)

- if you do some summary of all the commands
  and all the options for each of these commands,
  it could help to define better name.
  (give this abstract to read by someone for 5 mn, then
  ask him what does which command!)

> Do you think it is usable like that ?
> Have you noticed :
>      o some missing macros/features ?
>      o a bad macro name ?
>      o a bad paragraph in the doc ?
> Thank you for your support.
> Regards
> Dominique

Maurice.Diamantini at ensta.fr       -       ENSTA/LMA
École Nationale Supérieure  de  Techniques Avancées
 Laboratoire    de     Mathématiques    Appliquées 

More information about the PSTricks mailing list