[pdftex] Acrobat 6.0, pdfTeX, and CJK/Unicode incompatibility?

Roger Hart rhart at mail.utexas.edu
Thu Jan 1 01:25:03 CET 2004

I'm encountering a problem with Unicode characters (Chinese and 
Japanese in particular) in PDF files produced by pdftex.

I'm running Mac OS X 10.3.2, and have installed TeX (TeX Live and 
teTeX) using i-Installer.  And then (following very detailed 
instructions kindly provided by Olivier Delloye) I installed the 
following: (1)  the ucs package, (2) the CJK package, and (3) a Unicode 
True Type font (Bitstream Cyberbit).  I use TeXShop 1.34 as the front 
end, and typeset using LaTeX and  pdfTeX (which is version 1.11a). My 
LaTeX preamble includes: \usepackage[encapsulated]{CJK}; 
\usepackage{ucs}; and \usepackage[utf8]{inputenc}.

As someone on the OS X TeX list noted earlier, the CJK/Unicode 
characters sometimes do not display properly in Apple's Preview, and 
thus the same problem occurs in TeXShop's Preview. The suggestion was 
to instead view the output PDF file in Adobe Reader or Acrobat.

However, Acrobat Professional thinks there is something wrong in the 
encoding. While the characters are displayed correctly, and print 
correctly, there still seems to be a problem.  When I run the 
accessibility checker in Adobe Acrobat Professional 6.01 
(Advanced->Accessibility->Full Check), I get the following result:

	All of the text in this document lacks a language specification.

	723 words(s) inaccessible because they contain characters with no 
reliable mapping to Unicode.

	This document is not structured; the reading order of the contents may 
be incorrect.

If I then try to add tags (Advanced->Accessibility->Add tags to 
documents), Acrobat substitutes incorrect characters in some instances. 
Or sometimes Acrobat just crashes.  This add tags feature seems to work 
properly on documents without Chinese, and also works with PDF files 
created from MS Word, even with Chinese in the documents.

I have called Adobe support, and of course they state that the problem 
is not with Acrobat, but with pdfTeX, since it produced the PDF file.

I am not an expert in TeX and I have tried a number of admittedly 
simple-minded workarounds, such as attempting to print out as 
Postscript file and run Distiller, etc. I've also tried running the 
LaTeX files through other front ends, such as iTeXMac.  I've spent 
quite a bit of time trying to find a solution, without any success.  
Any suggestions?

Thanks very much for your help,



Roger Hart
Assistant Professor, Departments of History and Asian Studies
University of Texas at Austin

office: Room 405, Garrison Hall
office phone: 512-475-7258
department fax: 512-475-7222
email: rhart at mail.utexas.edu


More information about the pdftex mailing list