[pdftex] make (pdftex-20010126) pdftexbin fails on SUN gcc 2.95.2

Bill LANGDON W.Langdon at cs.ucl.ac.uk
Sat Mar 10 18:47:35 CET 2001

Dear Thanh,
           Many thanks for your helpful and speedy reply. I have
progressed the installation a little with your help.

  I have create and compiled dlsym.c as you suggested and inserted it
into a copy of libc.a  "make" fails kpsewhich as before as expected
and then I manually run:

gcc -o kpsewhich -static kpsewhich.o ../kpathsea/STATIC/libkpathsea.a /tmp/pdftex/libc.a -lm

which works fine and then I rerun make. 

It progresses much futher but then fails with:

gcc -o pdftex -static pdftexini.o pdftex0.o pdftex1.o pdftex2.o pdftex3.o pdftexextra.o pdftexdir/libpdf.a ../../libs/libtiff/libtiff.a ../../libs/libpng/libpng.a ../../libs/zlib/libz.a ../../libs/xpdf/xpdf/libxpdf.a ../../libs/xpdf/goo/libGoo.a lib/lib.a ../kpathsea/STATIC/libkpathsea.a /tmp/pdftex/libc.a /opt/gcc295/lib/gcc-lib/sparc-sun-solaris2.7/2.95.2/libgcc.a -lm
Undefined                       first referenced
 symbol                             in file
__builtin_delete                    pdftexdir/libpdf.a(pdftoepdf.o)
__builtin_new                       pdftexdir/libpdf.a(pdftoepdf.o)
__rtti_user                         ../../libs/xpdf/xpdf/libxpdf.a(GfxState.o)
terminate(void)                     pdftexdir/libpdf.a(pdftoepdf.o)
__builtin_vec_new                   pdftexdir/libpdf.a(pdftoepdf.o)
__builtin_vec_delete                ../../libs/xpdf/goo/libGoo.a(GString.o)
__rtti_si                           ../../libs/xpdf/xpdf/libxpdf.a(GfxState.o)
ld: fatal: Symbol referencing errors. No output written to pdftex
collect2: ld returned 1 exit status

The only doucmentation about these missing routines suggests they
should be in 
but they arent.
Possibly the compilation should be done with -fnobuiltin? -fPIC?

Is this what Himanshu Gohel <gohel at csee.usf.edu> meant by 
"the configuration didn't go correctly" ?
I'm afraid I did not understand your comments on "static linking on solaris:"

As always any help would be most welcome

Thank you

> > I have also tried restarting from scratch and running
> > configure --datadir=/opt/tex/lib --with-pdftex
> > (We have LaTeX installed in /opt/tex/bin/latex)
> > But make stopped again on kpsewhich
> > 
> > configure produced several lines like:
> > running /bin/sh ./configure  --datadir=/opt/tex/lib --with-pdftex --prefix=
>  /usr/local/teTeX --cache-file=../.././config.cache --srcdir=.
> > 
> > "--prefix=/usr/local/teTeX"
> > Is a bit suspicious? I don't have write access to it.
> > So I tried again (from the start) with
> > configure --datadir=/opt/tex/lib --with-pdftex --prefix=/tmp/pdftex
> > but make failed on kpsewhich as before:-(
> I also have this problem on a sun machine. The solution is following:
> ----------------------------------------------------------
> static linking on solaris:
> libkpathsea.a(tilde.o) -> getpwnam -> libc.a(getpwnam.o) -> _fgetpwent_r ->
> libc.a(getpwnam_r.o) -> _nss_getent -> libc.a(nss_common.o) ->
> nss_default_finders -> libc.a(nss_deffinder.o) -> 
> dlclose,dlsym,dlopen (undefined)
> Added  dlsym.o to libc.a:
>      void *dlopen() { return 0; }
>      void *dlsym()  { return 0; }
>      int dlclose()  { return -1; }
> ----------------------------------------------------------
> This comment comes from the documentation of kpathsea lib
> Regards,
> Thanh

More information about the pdftex mailing list