[pdftex] install pdftex 0.14h binary failed, please help.

White, George WhiteG at mar.dfo-mpo.gc.ca
Fri Apr 20 09:57:50 CEST 2001

This posting and the responses raise the issue of how best to
handle updates to various packaged distributions such as linux
teTeX, or SGI's freeware teTeX.  On single user systems, it may
enough to simply install updates over the vendor-supplied 
configuration, but even so this can create problems if you 
later want to install a newer version of the system.  In some
environments (NFS mounted systems, multi-user systems) only
administrators are allowed to change the vendor-supplied 
configuration.  It appears that many people attempt to work
around problems by setting environment variables such as
TEXINPUTS, which tends to defeat the purpose of the kpathsea

The teTeX system makes it easy to have personalized configurations.
You can do this by creating a web2c directory for a customized
texmf.cnf, format, pool files, etc.  Then set TEXMFCNF to the path
for this directory.  With this approach, the usual mechanism to
find texmf.cnf relative to the location of the binaries is 
not used, so you can install updated binaries in a new directory.
In this way you can test updates without overwriting your 
vendor-supplied files.  To switch back to the vendor configuration
you need only remove TEXMFCNF and change the search path.    


item 3+4)  you can edit "$TEXMFCNF/fmtutil.cnf" to determine which
formats are generated

item 6) you should follow the debugging instructions for the
kpathsea libraries to determine why the file isn't found.

-----Original Message-----
From: Lupei Zhu
To: pdftex at tug.org
Sent: 4/20/01 2:08 AM
Subject: [pdftex] install pdftex 0.14h binary failed, please help.


  I want to update pdftex on my RH7.0 PC (which was installed 14d by
redhat). I did as follows:

1) download file from ftp.muni.cz
2) unzip it and copy pdftex.pool, pdfetex.pool to
/usr/share/texmf/web2c, copy those excutables to /usr/bin
3) in web2c, run texconfig init. I found that it only regenerated
several other *.fmt files but not pdf*.fmt. So when I tried to  run
"pdflatex ...", I got error complaining wrong format.
4) I used followings to regenerate format files:
   pdftex -ini -fmt=pdftex plain \dump
   pdftex -ini -fmt=pdflatex latex.ltx
   pdfetex -ini -efmt=pdfetex plain \dump
   pdfetex -ini -efmt=pdfelatex latex.ltx
   all worked fine.
5) now run "pdftex -version", I got:

pdfTeX (Web2C 3.14159-0.14h-released-20010417
kpathsea version
Copyright (C) 1999 Han The Thanh, Petr Sojka, and Jiri Zlatuska.

6) but when I try to compile a tex file by "pdflatex aaa.tex", I got
this error
This is pdfTeX, Version 3.14159-14h-released-20010417 (Web2C
Error: pdflatex (file pdftex.cfg): cannot open config file

  I find that if I copy the file
/usr/share/texmf/pdftex/config/pdftex.cfg to the current directory, the
above works. I tried to set the TEXPSHEADERS to point that directory, it
doesn't help.

  I am stuck here. can anyone please help me? thanks alot.


pdftex mailing list
pdftex at tug.org

More information about the pdftex mailing list