[metapost] Problems to run mpost 1.206

Stephan Hennig mailing_list at arcor.de
Wed Aug 5 17:39:43 CEST 2009

Hi Carlos,

Carlos Ruiz Mora schrieb:
> Hello,
> I'm definitely new to MetaPost.


> I run the version that I got
> with MikTex ver 2.7. I run it throug Crimson Editor. When I include
> directives such as the one below (found in the MetaPost documentation
> for version 1.206):
>  ----------------------------------------------------------------------------------------------------
> outputtemplate := "%j-%3c.mps";----------------------------------------------------------------------------------------------------
> I get the following output message:
> -------------------------------------------------------------------------------------------------
>>> outputtemplate
>>> "%j-%3c.mps"
> ! Equation cannot be performed (numeric=string).
> <to be read again> 
>                    ;
> l.1 outputtemplate := "%j-%3c.mps";
> I'm sorry, but I don't know how to make such things equal.
> (See the two expressions just above the error message.)
> ------------------------------------------------------------------------------------------
> So, it seems that the manual is wrong because lists the variable
> outputtemplate as string when it is recognized as numeric by mpost.
> So, I found out that I was running version 1.005.

Yeah, the manual for MetaPost 1.206 is clearly the wrong reference for
Metapost 1.005.  The internal string variables outputtemplate and
outputformat have only been introduced in MetaPost 1.200.  Section B.2
in the manual for MetaPost 1.2xx has some hints about creating backwards
compatible MetaPost files.

To explain the error: in MetaPost 1.005 the line

  outputtemplate := "%j-%3c.mps";

tries to assign a string expression to an unknown variable named
"outputtemplate".  By default, unknown variables are initialized to be
of type numeric.  After that, the assignment fails with the correct
error message.

> So I decided to find the latest version, which is 1.206. I now run
> that version 1.206 but now I get the following message:

That won't work, as the mpost executable provided by Taco is not MiKTeX
compatible.  You should wait for Christian Schenk to update MiKTeX's
mpost executable.  (There is a way to run the latest mpost executable on
Windows, but I hope Mojca can drop in and help out with that.)

Best regards,
Stephan Hennig

More information about the metapost mailing list