[metapost] Problems to run mpost 1.206

Carlos Ruiz Mora caruizmo at yahoo.com
Wed Aug 5 07:07:59 CEST 2009


I'm definitely new to MetaPost. I run the version that I got
with MikTex ver 2.7. I run it throug Crimson Editor. When I include
directives such as the one below (found in the MetaPost documentation
for version 1.206):

outputtemplate := "%j-%3c.mps";----------------------------------------------------------------------------------------------------

I get the following output message:

>> outputtemplate

>> "%j-%3c.mps"

! Equation cannot be performed (numeric=string).

<to be read again> 


l.1 outputtemplate := "%j-%3c.mps";


I'm sorry, but I don't know how to make such things equal.

(See the two expressions just above the error message.)

So, it seems that the manual is wrong because lists the variable outputtemplate as string when it is recognized as numeric by mpost. So, I found out that I was running version 1.005. So I decided to find the latest version, which is 1.206. I now run that version 1.206 but now I get the following message:


---------- Capture Output ----------

> "C:\MetaPost\mpost.exe" Prueba2.mp

warning: kpathsea: configuration file texmf.cnf not found in these

Sorry, I can't find the 'mpost' mem file; will try 'plain'.

I can't find the 'plain' mem file!

> Terminated with exit code 1.

 So, I need help to understand what happens with the use of outputtemplate and how to make version 1.206 run normally. I get the same error even if I run it in console mode.

thanks a lot

PS: this is the test code I'm trying to run

outputtemplate := "%j-%3c.mps";
    fill fullcircle scaled 5cm withcolor red;
    pair A, B, C;
    A:=(0,0); B:=(1cm,0); C:=(0,1cm);
    draw A--B--C--cycle;

This is supposed to generate two files which names should be "fig-001.mps" and "fig-002.mps" according to the documentation for version 1.206

¡Obtén la mejor experiencia en la web!
Descarga gratis el nuevo Internet Explorer 8. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/metapost/attachments/20090804/500be14b/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mpman.pdf
Type: application/pdf
Size: 844854 bytes
Desc: not available
URL: <http://tug.org/pipermail/metapost/attachments/20090804/500be14b/attachment-0001.pdf>

More information about the metapost mailing list