[metapost] Getting "fatal mem file: i'm stymied" on RH4

Dan Luecking luecking at uark.edu
Thu Apr 30 23:40:51 CEST 2009

At 02:26 PM 4/30/2009, Stephen Gross wrote:
>Hi folks. I'm getting the universal "Fatal mem file error: I'm 
>stymied" error message. Here's my setup:

This means the file mpost.mem can't be found or hasn't
been updated since the last binary update, or the wrong
one was found on a system that has more than one.

For the first, try
   kpsewhich mpost.mem
to see if the file exists (and perhaps note where it is located).
[Recent versions of kpathsea require
   kpsewhich --engine=metapost mpost.mem]

For the second, run
   fmtutil --byfmt mpost
(or possibly fmtutil-sys)

There are so many ways for the last to happen it is hard to
say what to do, but at least try to find out if the mpost
executable file is in the same general tree as mpost.mem.
In my case, the mpost binary is in
and the mem file is in
since mpost looks in descendents of its grandparent directory
for mem files, this is the normal pattern. However, values of
the variable MPMEMS can change this.

>   mpost <http://foo.mp>foo.mp
>Foo.mp's contents: <empty> (also tried with a non-empty .mp file--same result)

These are irrelevant: mem-file errors happen when mpost is
initializing itself, even befor the filename is processed.


Daniel H. Luecking
Department of Mathematical Sciences
University of Arkansas
"Dubito ergo cogito, cogito ergo sum" --Descartes

More information about the metapost mailing list