[metapost] Problem with label in Metapost

M sah_8 at yahoo.com
Sat Jan 5 17:47:26 CET 2008


I am new user of Metapost. I tried to draw some simple figures mentioned in the manual.  It works fine without label. But  there is problem with label. The code is
a=.7in; b=.5in;
draw z1..z2..z3..z4..cycle;
draw z1--z0--z2;
label.top("a", .5[z0,z1]);
label.lft("b", .5[z0,z2]);
dotlabel.bot("(0,0)", z0);

The log file says:
This is MetaPost, Version 0.641 (Web2C 7.5.4) (mem=mpost 2007.11.24)  5 JAN 2008 11:40
(test.mp [17])
1 output file written: test.17

But when I tried to open with ghostscript, it say some error:
ERROR: /undefined in cmr10ESP Ghostscript 815.04: Unrecoverable error, exit code 1

Operand stack:
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--
Dictionary stack:
   --dict:1123/1686(ro)(G)--   --dict:0/20(G)--   --dict:102/200(L)--
Current allocation mode is local
Current file position is 607

I am using Linux (Fedora Core 6 with everything up-to-date).
Any help will be appreciated.


Be a better friend, newshound, and know-it-all with Yahoo! Mobile.  Try it now.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://tug.org/pipermail/metapost/attachments/20080105/2521b4a6/attachment.html 

More information about the metapost mailing list