[OS X TeX] \jobname works in 2013 but not in 2020

Alain Schremmer schremmer.alain at freemathtexts.org
Tue Sep 22 23:34:17 CEST 2020

> On Sep 18, 2020, at 8:25 PM, Herbert Schulz <herbs at wideopenwest.com> wrote:
>> On Sep 18, 2020, at 6:30 PM, John Collins <jcc8 at psu.edu> wrote:
>> On 9/18/20 3:30 PM, Herbert Schulz wrote:
>>> Thanks for the information. I've changed that to using the scrlayer-scrpage package and can get past that problem now.
>>> However, now I run into another error about writing files:
>>> pdflatex: Not writing to ../Text-contents/1.aux (openout_any = p).
>>> So it appears that there is need for a configuration change of TeX Live to permit that operation.
>> Small comment: There's no need to load Justin's preamble package. Comment out the \usepackage line in the document files, and exactly the same error occurs. So the MWE isn't really an MWE.
>> In any case, Herb's diagnosis is correct.  If you change each \include to \input, compilation goes through without problems.
>> John Collins
> Howdy,
> OK!
> Changing 
> \usepackage[nouppercase]{scrpage2}
> to
> \usepackage[nouppercase]{scrlayer-scrpage}
> in MWE/Stylesheets/Preamble.sty AND changing the TeX Live 2020 configuration variable from `openout_any = p` to `openout_any = a` it all seems to work fine. I don't like it, but it works.
> Still not smiling. :-(

1. Well, then, and since I had failed to inquire about your drinking tastes, I will commute the case of beer into bottles of wines. Please let me know what would suit you. And, right after the virus has died, I fully expect you to come pick them up … and admire my construction work which is much better than my LaTeX work.

2. Sorry for not responding earlier but during the extended weekends I still indulge a bit in construction work and then today I had to check the suggestions against the MagnumOpus because one fix always risks demolishing something else. So, here is MWE_complete-1 that incorporates most features of the MagnumOpus itself:

— I removed—and didn't replace---the <scrpage2> package which I had put in just so as not to have caps in the running headings. I will worry about that later.

— I changed “include" to “input" which does not seem to make any difference.  (Presumably because all I am inputting are chapters. Right?)

— I did not even attempt the reconfiguration of openout_any because I remember doing something like that once upon a time (2013?) and it sure isn’t a pleasant memory. So, could someone hold my hand?

3. MWE_complete-1 works fine under 2013 but still not under 2020 which, with all grateful respect I owe Collins---whose LaTeXMark I couldn’t live without, makes it a working example … of what’s wrong with all these upgrades of TeXlive: what would I do without this list when I have to “upgrade”?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/macostex-archives/attachments/20200922/8cfd996d/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: MWE_complete-1.zip
Type: application/zip
Size: 33112 bytes
Desc: not available
URL: <https://tug.org/pipermail/macostex-archives/attachments/20200922/8cfd996d/attachment-0001.zip>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/macostex-archives/attachments/20200922/8cfd996d/attachment-0003.html>
-------------- next part --------------
----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: https://sites.esm.psu.edu/~gray/tex/
List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the macostex-archives mailing list.