[OS X TeX] \jobname works in 2013 but not in 2020

Herbert Schulz herbs at wideopenwest.com
Sat Sep 19 02:25:17 CEST 2020

> On Sep 18, 2020, at 6:30 PM, John Collins <jcc8 at psu.edu> wrote:
> On 9/18/20 3:30 PM, Herbert Schulz wrote:
>> Thanks for the information. I've changed that to using the scrlayer-scrpage package and can get past that problem now.
>> However, now I run into another error about writing files:
>> pdflatex: Not writing to ../Text-contents/1.aux (openout_any = p).
>> So it appears that there is need for a configuration change of TeX Live to permit that operation.
> Small comment: There's no need to load Justin's preamble package.  Comment out the \usepackage line in the document files, and exactly the same error occurs. So the MWE isn't really an MWE.
> In any case, Herb's diagnosis is correct.  If you change each \include to \input, compilation goes through without problems.
> John Collins







in MWE/Stylesheets/Preamble.sty AND changing the TeX Live 2020 configuration variable from `openout_any = p` to `openout_any = a` it all seems to work fine. I don't like it, but it works.

Still not smiling. :-(

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: https://sites.esm.psu.edu/~gray/tex/
List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the macostex-archives mailing list.