[OS X TeX] "file not found"

Nitecki, Zbigniew H. Zbigniew.Nitecki at tufts.edu
Thu Aug 9 05:39:11 CEST 2018

I am running into a confounding problem.  I wanted to build a source file for a paper by inputting separate sections into a master file (ie, in masterfile.tex, have a line “\input{section}”, and creating separately a file

I think I have done this successfully before.  This time, the first input worked.  Then I tried to input into the section the contents of a file subsection.tex, in the same way—that is, via a command “\input{subsection}”.  (Note that all three are in the same folder).
I got an error “ Latex error: can’t find file subsection.tex”.
So I tried instead, in masterfile.tex, to follow the first command \input{section} with a second command \input{subsection}.  Same error message.

The file names I initially worked with are different, but that is the essence of the problem.

So I tried to create a “minimal example”.  Here are two files, sitting in the same folder:
InputTest has just a standard latex template, followed by “\input{first section}”.

Trying to compile this, I get the error message “can’t find file first section.tex”.  (that is, this time even the first input doesn’t work)  Here is the log file:

Zbigniew Nitecki
Department of Mathematics
Tufts University
Medford, MA 02155

Office    (617)627-3843
Dept.    (617)627-3234
Dept. fax    (617)627-3966

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/macostex-archives/attachments/20180809/6021b785/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: first section.tex
Type: application/octet-stream
Size: 52 bytes
Desc: first section.tex
URL: <https://tug.org/pipermail/macostex-archives/attachments/20180809/6021b785/attachment-0003.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: InputTest.tex
Type: application/octet-stream
Size: 800 bytes
Desc: InputTest.tex
URL: <https://tug.org/pipermail/macostex-archives/attachments/20180809/6021b785/attachment-0004.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: InputTest.log
Type: application/octet-stream
Size: 11346 bytes
Desc: InputTest.log
URL: <https://tug.org/pipermail/macostex-archives/attachments/20180809/6021b785/attachment-0005.obj>
-------------- next part --------------
----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: https://sites.esm.psu.edu/~gray/tex/
List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the macostex-archives mailing list