[OS X TeX] How tell MacTeX 2016 about fonts in user tree?

Murray Eisenberg murrayeisenberg at gmail.com
Tue Jun 7 21:46:30 CEST 2016

Murray Eisenberg wrote
> Herbert Schulz wrote
>>> On Jun 7, 2016, at 12:22 PM, Murray Eisenberg <

>> murrayeisenberg@

>> > wrote:
>>> OK, I ran just `updmap`, with following results:
>>> updmap will read the following updmap.cfg files (in precedence order):
>>>  /Users/murray/Library/texmf/web2c/updmap.cfg
>>>  /usr/local/texlive/2016/texmf-dist/web2c/updmap.cfg
>>> updmap may write changes to the following updmap.cfg file:
>>>  /Users/murray/Library/texmf/web2c/updmap.cfg
>>> dvips output dir:
>>> "/Users/murray/Library/texlive/2016/texmf-var/fonts/map/dvips/updmap"
>>> pdftex output dir:
>>> "/Users/murray/Library/texlive/2016/texmf-var/fonts/map/pdftex/updmap"
>>> dvipdfmx output dir:
>>> "/Users/murray/Library/texlive/2016/texmf-var/fonts/map/dvipdfmx/updmap"
>>> updmap [ERROR]: The following map file(s) couldn't be found:
>>> updmap [ERROR]: 	ztmsc.map (in
>>> /Users/murray/Library/texmf/web2c/updmap.cfg)
>>> updmap [ERROR]: Did you run mktexlsr?
>>> 	You can disable non-existent map entries using the option
>>> 	  --syncwithtrees.
>> Have you changed fonts? Do you have a ztmsc.map file somewhere (wrong
>> place)? I don't know what font that is for but I'm guessing it has
>> something to do with Small Caps for the ztm font. Does the
>> ~/Library/texmf/web2c/updmap.cfg file exist and what are its contents?
> (1) Contents of ~/Library/texmf/web2c/updmap.cfg:
> Map lucida.map
> Map mtpro2.map
> Map wolfram.map
> #! Map pdfwolfram.map
> Map mathpi.map
> Map MinionPro.map
> Map zgm.map
> Map ugm.map
> Map ua1.map
> Map uop.map
> Map dayroman.map
> Map zpeu.map
> Map ulg.map
> Map ul9.map
> Map webo.map
> Map ztmsc.map
> (2) The font in question is indeed Adobe Times Small Caps (for which I
> have the Adobe-furnished font files).
> (3) I have made utterly no change whatsoever to my fonts since the last
> time, with MacTeX/TexLive 2015, that I updated packages by running the TeX
> Live Utility (with its preference set to automatically enable fonts in my
> home directory.
> (4) I do NOT find a file `ztmsc.map` anywhere. But this has not changed
> since running the 2015 Tex Live Utility.
> (5) I do not have any directory  `~/Library/texlive/2016` such as is
> mentioned in the output from my running `updmap` manually after upgrading
> to MacTeX 2016. And so no subdirectories
> `~/Library/texlive/2016/texmf-var/fonts/map/dvips`, etc.
> (6) The problem is doubtless related to the issue described in the thread
> beginning at 
>       http://tug.org/pipermail/macostex-archives/2014-August/052776.html
> but I again I note that I have made no changes to fonts myself since
> upgrading from 2015 to 2016 (other than manually running `updmap` per
> suggestion)

I think I found the root of the problem: I had never copied Michael Sharpe's
newtxc package files into my `~/Library/texmf`. 

I did that now and ran `updmap` manually, getting _no_ error message this

But I'm still perplexed as to why I got the error the first time I ran
`updmap` manually after upgrading to MacTeX 2016, yet never saw any such
error when using the 2015 TeX Live Utility regularly with the "Automatically
enable fonts in my home directory" prefers active (and no font changes on my

View this message in context: http://macosx-tex.576846.n2.nabble.com/How-tell-MacTeX-2016-about-fonts-in-user-tree-tp7585771p7585790.html
Sent from the MacOSX-TeX mailing list archive at Nabble.com.

----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: https://www.esm.psu.edu/~gray/tex/
List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the macostex-archives mailing list