[OS X TeX] Can't find required tool

Richard J Benish rjbenish at comcast.net
Wed Aug 31 18:14:03 CEST 2016

>  > On Aug 30, 2016, at 9:57 PM, Richard J Benish <rjbenish at comcast.net> wrote:
>>  Greetings,
>>  On a G5 with Mac OS 10.4.11, I've been using TeXShop v 2.33 for 
>>years. Without consciously having changed anything to affect the 
>>program, suddenly, when I hit the typeset button I get the error 
>>  "Can't find required tool.
>>  "/usr/texbin/pdflatex does not exist. Perhaps TeXLive was not 
>>installed or was removed during a system upgrade. If so, go to the 
>>TeXShop web site and follow the instructions to (re)install 
>>TeXLive. Another possibility is that a tool path is incorrectly 
>>configured in TeXShop preferences. This can happen if you are using 
>>the fink teTeX distribution."
>>  I've tried restarting, correcting permissions, and reinstalling. 
>>After failing to find an old install version on the web, I tried 
>>installing from a locally saved copy of:
>>  MacTeX-2011.mpkg
>>  This resulted in a grayed out list of components which, when I 
>>clicked on INSTALL, resulted in an error saying "There is nothing 
>>to Install." Could that be because the non-functioning version 
>>needs to be uninstalled first? If so I hesitate to do so before 
>>getting confirmation.
>>  I've haven't found anything on the web to get me back to a 
>>properly functioning application.
>>  Any ideas?
>>  Thanks.
>>  Richard Benish
>First... are you sure your not having Hard Disk problems?
>In Terminal please run the five commands
>which pdflatex
>ls -alF /
>ls -alF /usr
>ls -alF /usr/local
>ls -alF /usr/local/texlive
>and let us know the results.
>Good Luck,
>Herb Schulz
>(herbs at wideopenwest dot com)

Thanks Herb,

I've attached the Terminal session with the five questions and 
answers in the order that you gave them.

The last one says

"ls: /usr/local/texlive: No such file or directory"

If the file is supposed to be findable, I have no idea how it got lost.

I ran a MacOS hard drive diagnostic and passed. I've not had any 
problems with the drive. It is less than a year old.

It's been a few weeks since I used LaTeX, but at that time, 
everything worked fine--as it has for years. It would be nice to have 
all new(er) stuff. My motorized transport just turned 50. It's got a 
Slant-6. :) I really like my G5 and OS 10.4.11. And I'm broke.

Thank you very much for your help and your patience.

Rick Benish
-------------- next part --------------
A non-text attachment was scrubbed...
Name: LaTeX Five Questions Aug 31 2016.term
Type: application/octet-stream
Size: 5701 bytes
Desc: not available
URL: <http://tug.org/pipermail/macostex-archives/attachments/20160831/4c460ad6/attachment-0001.obj>
-------------- next part --------------
----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: https://www.esm.psu.edu/~gray/tex/
List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the macostex-archives mailing list