[OS X TeX] TeXShop/SyncTex erratic behaviour

Patrick Wambacq patrick.wambacq at esat.kuleuven.be
Wed Apr 20 16:08:20 CEST 2016


I have a large file with almost 400 beamer slides and SyncTex behaves erratically: the inverse search (from pdf to source) always works, the forward search (from source to pdf) sometimes works, most of the times not. It can fail when clicking on the same position where it did not fail before (without changing the source). I tried to find a minimal example that shows this behaviour but couldn't. When I threw out say half of the slides, it worked (although I didn't try to click everywhere, of course). Gradually adding slides to this subset until the misbehaviour appeared was possible (which is a too large example to submit here), but when I then isolated the slides that were added and typeset those alone, there was no problem.

In the preferences, the SyncTex method is selected. When I select "Both Pdf Sync and Search" the problem has gone. I already thrashed the preferences and restarted but that does not help. I have not encountered problems with other source files that I tried. This is TL2015, updated with the latest possible packages, and the latest TeXShop 3.61, osx 10.10.5. This happens both on my laptop and desktop mac (running the same versions). A colleague who works with the same slides has no problems with SyncTex using MiKTeX/Texmaker on Windows.

Any suggestions? Something that I can try to narrow down the problem?


----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: https://www.esm.psu.edu/~gray/tex/
List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the macostex-archives mailing list