[OS X TeX] Disaster

Herbert Schulz herbs at wideopenwest.com
Sat Aug 22 18:54:20 CEST 2015

> On Aug 22, 2015, at 11:23 AM, George Gratzer <gratzer at me.com> wrote:
> Dick,
> This was traumatic, but problems solved.
> On the MacBook Air, somehow it did not read in the definition of \MathOrText,
> causing hundreds of mistakes. I eliminated all, this problem is fixed.


This is very strange. For 2015 LaTeX incorporates fixltx2e in the kernel so the command should always be there; no need to load fixltx2e. I checked this with a very small file and it worked fine.

%%!TEX TS-program = pdflatex
\newcommand{\TOM}{\TextOrMath{x squared}{x^{2}}}
First \TOM\ or \(\TOM\) or $\TOM$.

> Independently, the source file was corrupted, a big chunk replicated itself.
> I have never seen anything like this before.

How did you fix things up? Did you have a backup (I hope so)?

> Coincidence, but who believes in coincidences? Two computers, same time.

Was it really the same time? Both compiling files in their synced DropBox folder?

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list