[OS X TeX] Disabling URW fonts

Herbert Schulz herbs at wideopenwest.com
Wed Jan 22 23:14:29 CET 2014

On Jan 22, 2014, at 3:52 PM, Dennis Kletzing <dkletzing at cfl.rr.com> wrote:

> Herb and Michael:
> I ran your lines
>>> updmap --setoption LW35 ADOBE
> that didn’t do anything, so I ran
>>> sudo -H updmap-sys --setoption LW35 ADOBE
> which also didn’t do anything, so I tried Herb’s suggestion about a new updmap.cfg file and running 
>> sudo -H mktexlsr
> and
>> sudo -H updmap-sys
> None of these worked. I get this error line:
> /usr/texbin/dvips: ! Couldn't find font file com_____.pfb
> ### FAILED to generate /tmp/altpdflatex.14838-1390426880/epprep1.ps ()
> So I went back to the original updmap.cfg file and ran the sudo -H updmap-sys.
> I’m afraid I messed things up because I can no longer get back to the original situation of having the urw fonts used in place of the core 35 fonts. I can’t compile anything that uses a times font. Is it possible to get back to the original setup? Is it possible to reinstall TeXLive 2013 or revert to the original files?
> --
> Dennis Kletzing


Do you really have com_____.pfb on your system? I.e., are the ADOBE .pfb files actually installed?

To go back remove the updmap.cfg file in /usr/local/texlive/texmf-local/web2c and run

sudo -H mktexlsr

so that the TeX Distribution `forgets' it existed. Then run

sudo -H updmap-sys --setoption LW35 URWkb

and it should be back to the URW fonts.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list