[OS X TeX] Command completion troubles

Don Green Dragon fergdc at Shaw.ca
Sat Aug 30 18:44:13 CEST 2014

Hi Herb,

I’m attaching a 30KB file


as you specified. The version that I’ve attached is the one which appeared in 


after another unsuccessful trial.

Not sure if you intended that «CommandCompletion.txt»  be sent to your <herbs at wideopenwest.com> mailbox or here. Sorry, if  it should not go to this list.

I read your other Email about the details  of typing in

\sec «trigger»

before the trial  and I was lucky ;—) as I had not hit «RETURN» before the «trigger» 

Sad story is that command completion still does not work. 

I was not entirely sure what you meant by «Then try to open a new file» so I first tried it on one of my existing .tex files and it failed. So I quit TeXShop, dragged the «Command Completion»  directory to the desktop. When I opened TeXShop again, I loaded that «LaTeX Template» and then tried 

\sec «trigger»

No luck! I guessed that maybe my prelude stuff was screwing things up whereas the «LaTeX Template» should be `pure’ in some vague sense. So the attachment «Command Completion.txt» comes from the trail using «LaTeX Template».

On 27Aug2014, at 1:31 PM, Herbert Schulz <herbs at wideopenwest.com> wrote:

> On Aug 27, 2014, at 2:14 PM, Don Green Dragon <fergdc at shaw.ca> wrote:
>> With respect to my settings. Checking «Source -> Key Bindings -> Toggle On/Off» I see that the 
>> «Toggle On/Off» part is checkmarked.
>> Looking in «TeXShop -> Preferences -> Source -> Command Completion Triggered By:» I find that «Escape Key» is active.
>> The two settings above have been that way forever, a long time!!, I think.
>> With respect to command completion: Relative your example \sec. In a source file which is active and performing well, I type
>> \sec
>> with a blank line above, as shown, then press the `Trigger’, which is the ESC key, and nothing happens. The behaviour used to be as you described. I get the same `no action’ response with
>> \benu  «press trigger» 
>> So somewhere, somehow I must have disabled command completion, but where would that have been done?
>> Thanks for your always helpful advice.
> Howdy,
> There is no toggle for Command Completion since it takes an active press of the trigger to engage it.
> Please Quit TeXShop, Open ~/Library/TeXShop and move the CommandCompletion folder to the Desktop and finally Open TeXShop again. Then try to open a new file, place
> \sec
> at the start of a line and press the trigger (Esc in your case) key. If nothing happens please send me a copy of the CommandCompletion.txt file found in ~/Library/TeXShop/CommandCompletion.

As noted above, the file is attached with this mail.

> Please remember that ~/Library is the Library folder in you HOME folder (NOT /Library which is the Library folder at the base of your Hard Drive). Under OS X 10.7 and later ~/Library is hidden by default. To Open it Click on the Go Menu in Finder and press the Opt key so that the new Library item shows in the menu.

Believe it or not, I understood the above!  ;—)  Thanks for your unending patience. 

don green dragon
fergdc at shaw.ca

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: CommandCompletion.txt
URL: <http://tug.org/pipermail/macostex-archives/attachments/20140830/e337bcc2/attachment.txt>

More information about the macostex-archives mailing list