[OS X TeX] Command completion troubles

Don Green Dragon fergdc at Shaw.ca
Mon Aug 25 21:27:53 CEST 2014

Hello All, 

This is essentially directed to Herb and is related to his reply to Alain Schremmer concerning ``List of feature requests on this list’’ but I thought that a new subject was in order.

Some time ago command completion used to work, although I used it sparingly, but at some point in the past I’ve somehow ``turned it off’’ through ignorance, not intent.

I think it was caused by my effeor to eliminate the automatic appearance of {} upon entering

\_	i.e., backslash followed by underscore

In other words, I prefer to enter {} manually when needed. I cannot recall how I did that. Anyway I’ve been trying to re-establish command completion without success. I’m using

TeXShop 3.39 and the OS is Mavericks 10.9.4

and fairly recently (two weeks ago??) installed MacTeX 2014 and even ran the TeXLive utility thing thereafter. As usual TeXShop is beautiful, but it would be nice to regain that command completion stuff.

I tried to follow Herb’s document:

Using Command Completion with TeXShop  2012/05/14	(the .pdf file)

and did the following:

-1- Changed the name of the directory


-2- Quit TeXShop and then re-opened it.

-3- Checked that a `new' directory ~/Library/TeXShop/CommandCompletion/ had been created, and it    had and seemed to have all the stuff that the OLD guy had contained.

-4- Opened an existing  small .tex file and attempted to invoke the various examples in Herb’s PDF. None of them worked!

The \_{} response still  does not appear, as desired. I looked in Herb’s ``Tips & Tricks’’ again and am now convinced that I used the "Macros -> Open Macros Editor" guy for TeXShop and changed something.

Any suggestions?

don green dragon
fergdc at shaw.ca

More information about the macostex-archives mailing list