[OS X TeX] Lost floats

Herbert Schulz herbs at wideopenwest.com
Wed Aug 20 17:37:24 CEST 2014

On Aug 20, 2014, at 9:52 AM, Nitecki, Zbigniew H. <Zbigniew.Nitecki at tufts.edu> wrote:

> Even more curious.  If I comment out the text for the equation* environment, the floats continue to disappear (so it is not the actual material inside the equation*).  When I replace the equation* environment with in-line equation (i.e., $…$), with the content of the equation* included,  the floats reappear.  
> Now, uncommenting more, later material (including some other equation* environments), all goes well, until I come to a list: an "itemize" environment, with several items.  Most of these items have no effect on the floats (i.e., they don't disappear), except for a single item
>> \item The statement that $\Levof{f}{c}\cap R$ is the graph of \phiof{x} means that the function
>> \phiof{x} is uniquely determined by \refer{eqn}{implicitfunct}.
> (I am no longer trying to replace the macros here with their definitions, because in the past the content appeared not to be the problem. ) If the itemize environment has only this item, the floats disappear.  If I comment this out but include the other 3-4 items, the floats reappear.  And if then I again uncomment the single item (leaving the others uncommented)  the floats disappear again.
> "What a long, strange trip…"
> On Aug 20, 2014, at 10:29, "Nitecki, Zbigniew H." <Zbigniew.Nitecki at tufts.edu>
>  wrote:
>> Help!
>> I have no idea even how to approach this problem.
>> I am getting lost floats messages (which I did not get before) when I include in my text (a few pages before the given floats) the following totally innocuous equation:
>> *************************************************
>> \begin{equation*}
>> g_{a}(y_{0}-\delta_{2})<0<g_{a}(y_{0}+\delta_{2})
>> \end{equation*}
>> ****************************************************
>> and when I comment out just this equation the floats no longer disappear.
>> What can possibly be causing this kind of behavior?
>> Z
>> On Aug 18, 2014, at 17:23, "Nitecki, Zbigniew H." <Zbigniew.Nitecki at tufts.edu> wrote:
>>> I am totally dumbfounded on this.
>>> I totally commented out everything I had been tinkering with, and the floats worked fine.  Then I started uncommenting bits;  I narrowed at least one source of the problem to the following equation:
>>>> \begin{equation*}
>>>> \gsof{a}{\yso-\delts{2}}<0<\gsof{a}{\yso+\delts{2}}
>>>> \end{equation*}
>>> and have dredged up all the definitions of the macros used in it:
>>>> \newcommand{\gsof}[2]{\ensuremath{\subof{g}{#1}{#2}}}% subscripted function g
>>>> \newcommand{\subof}[3]{\of{#1_{#2}}{#3}}%subscripted function of
>>>> \newcommand{\ys}[1]{\ensuremath{y_{#1}}}%subscripted y
>>>> \newcommand{\yso}{\ys{0}}
>>>> \newcommand{\delts}[1]{\ensuremath{\delta_{#1}}}%subscripted delta
>>> Nothing unusual that I can see.  But this is at least one of the culprits: when I comment out this equation, the floats all work fine.  When I then uncomment JUST those three lines (the equation) from what just worked, two of the floats get lost.
>>> Huh????
>>> Z
>>> On Aug 18, 2014, at 15:33, Herbert Schulz <herbs at wideopenwest.com>
>>>  wrote:
>>>> On Aug 18, 2014, at 1:22 PM, Nitecki, Zbigniew H. <Zbigniew.Nitecki at tufts.edu> wrote:
>>>>> I'm encountering a rather disastrous problem for which I can't provide a minimal example, since it is the maximal structure that seems to be causing it.  I'm asking for suggestions on how to trouble shoot it.
>>>>> Here is the situation:  I am revising a large book project, and in particular I have a set of pst-3D pictures set up in complicated floats (with sub floats, etc).  These have never caused problems until just now.  I was tinkering with some text several pages before these floats when I started getting the error message "Floats lost".  I tried to track down what was causing this problem, and ultimately commented out the whole section of text (which has no direct connection to the floats in question--they are in a different section  ) which resulted in still getting the error message, but the floats which get lost seem to vary with what I comment out in the text.  (That is, some lost ones reappear, but others disappear) I have no idea how to proceed from here, since anything that might have been embedded in the text I was tinkering with has been commented out, and before I started tinkering there was no error message.
>>>>> I seemed to recall that in the previous version of this book project I ran into some problems having to do with memory--I think--and it was resolved by following each of these megafloats with the line "\afterpage{\clearpage}".  I found one of these commented out in my present version and restored it--again changing which floats get lost, but not the fact that some are always being lost.
>>>>> Any ideas?
>>>>> Zbigniew Nitecki
>>>>> Department of Mathematics
>>>>> Tufts University
>>>>> Medford, MA 02155
>>>> Howdy,
>>>> My first guess (and it's only a guess) is that LaTeX can't find an ``acceptable'' location for the floats because of the added text. I'm not sure how you fix that but others here should be able to help.
>>>> Good Luck,
>>>> Herb Schulz
>>>> (herbs at wideopenwest dot com)
>>> Zbigniew Nitecki
>>> Department of Mathematics
>>> Tufts University
>>> Medford, MA 02155
>> Zbigniew Nitecki
>> Department of Mathematics
>> Tufts University
>> Medford, MA 02155
> Zbigniew Nitecki
> Department of Mathematics
> Tufts University
> Medford, MA 02155


Now it's beginning to sound like a list environment of some sort that isn't being closed; i.e., no \end{...}.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list