[OS X TeX] Lost floats

Nitecki, Zbigniew H. Zbigniew.Nitecki at tufts.edu
Mon Aug 18 23:23:22 CEST 2014

I am totally dumbfounded on this.
I totally commented out everything I had been tinkering with, and the floats worked fine.  Then I started uncommenting bits;  I narrowed at least one source of the problem to the following equation:
and have dredged up all the definitions of the macros used in it:
\newcommand{\gsof}[2]{\ensuremath{\subof{g}{#1}{#2}}}% subscripted function g
\newcommand{\subof}[3]{\of{#1_{#2}}{#3}}%subscripted function of
\newcommand{\ys}[1]{\ensuremath{y_{#1}}}%subscripted y
\newcommand{\delts}[1]{\ensuremath{\delta_{#1}}}%subscripted delta

Nothing unusual that I can see.  But this is at least one of the culprits: when I comment out this equation, the floats all work fine.  When I then uncomment JUST those three lines (the equation) from what just worked, two of the floats get lost.


On Aug 18, 2014, at 15:33, Herbert Schulz <herbs at wideopenwest.com<mailto:herbs at wideopenwest.com>>

On Aug 18, 2014, at 1:22 PM, Nitecki, Zbigniew H. <Zbigniew.Nitecki at tufts.edu<mailto:Zbigniew.Nitecki at tufts.edu>> wrote:

I'm encountering a rather disastrous problem for which I can't provide a minimal example, since it is the maximal structure that seems to be causing it.  I'm asking for suggestions on how to trouble shoot it.
Here is the situation:  I am revising a large book project, and in particular I have a set of pst-3D pictures set up in complicated floats (with sub floats, etc).  These have never caused problems until just now.  I was tinkering with some text several pages before these floats when I started getting the error message "Floats lost".  I tried to track down what was causing this problem, and ultimately commented out the whole section of text (which has no direct connection to the floats in question--they are in a different section  ) which resulted in still getting the error message, but the floats which get lost seem to vary with what I comment out in the text.  (That is, some lost ones reappear, but others disappear) I have no idea how to proceed from here, since anything that might have been embedded in the text I was tinkering with has been commented out, and before I started tinkering there was no error message.

I seemed to recall that in the previous version of this book project I ran into some problems having to do with memory--I think--and it was resolved by following each of these megafloats with the line "\afterpage{\clearpage}".  I found one of these commented out in my present version and restored it--again changing which floats get lost, but not the fact that some are always being lost.

Any ideas?

Zbigniew Nitecki
Department of Mathematics
Tufts University
Medford, MA 02155


My first guess (and it's only a guess) is that LaTeX can't find an ``acceptable'' location for the floats because of the added text. I'm not sure how you fix that but others here should be able to help.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: http://email.esm.psu.edu/mac-tex/
List Archive: http://tug.org/pipermail/macostex-archives/
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

Zbigniew Nitecki
Department of Mathematics
Tufts University
Medford, MA 02155

Office    (617)627-3843
Dept.    (617)627-3234
Dept. fax    (617)627-3966

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/macostex-archives/attachments/20140818/3c0fc923/attachment.html>

More information about the macostex-archives mailing list