[OS X TeX] ntheorem and the equation environment

Don Green Dragon fergdc at shaw.ca
Mon Jan 7 01:03:30 CET 2013

Hi Themis,

At last I got around to examining your reply with care.

On 16Jun2012, at 5:05 AM, Themis Matsoukas wrote:

> On Jun 15, 2012, at 11:02 PM, Don Green Dragon wrote:
>> Hi All,
>> For some months now, I've been using the ntheorem package in my basic template. 
> [...]
>> Everything has been working well until I recently noticed that source code of the form
>> \begin{equation} . . .  \end{equation}
>> does not work. Even something as simple as 
> The following worked for me:
> \documentclass [11pt, fleqn, leqno] {book}
> \usepackage[amsthm, thmmarks, framed, thref]{ntheorem}
> \usepackage{framed}
> \theoremstyle{marginbreak} \theoremheaderfont{\normalfont\bfseries}\theorembodyfont{\slshape} \theoremsymbol{\ensuremath{\diamondsuit}}
> \theoremseparator{:}
> \newtheorem{Theorem}{Theorem}
> \begin{document}
> Everything has been working well until I recently noticed that source code of the form
> \begin{Theorem}
> My theorem proves that
> \begin{equation}
> 	a  + b + c = d
> \end{equation}
> \end{Theorem}
> \end{document}

After examining your code and comparing with mine, eventually I discovered the main difference. The solution turned out to be:

1  \usepackage{amsmath}
2  \documentclass [11pt, fleqn, leqno] {book}
3  \usepackage[amsmath, amsthm, thmmarks, framed, thref]{ntheorem}
4  \usepackage{framed}

The line numbers are just for reference. I was surprised to find that you did not include line 1. So, in my basic template, I commented it out and tried to typeset. To my astonishment, the template typeset and the equations appeared that had been set with \begin{equation} . . . \end{equation}, however, other problems showed up with respect to the missing line 1. It was not until I modified the call to package {ntheorem}, shown in line 3 above, that the complaints vanished and consistent typesets followed. The added option in line 3 is mentioned in the May & Schedler manual.

I had placed line 1 where it is located above due to the following from the May & Schedler manual:

	"Note, that amsmath has to be loaded before ntheorem since the definitions have to be overwritten."

but I had ignored the advice about including 'amsmath' as an option for the {ntheorem} package.

Many thanks for your example, it cleared up a major problem here. 

Don Green Dragon
fergdc at Shaw.ca

More information about the macostex-archives mailing list