[OS X TeX] Locked Source Files

Nitecki, Zbigniew H. Zbigniew.Nitecki at tufts.edu
Mon Feb 4 00:02:52 CET 2013

Recent versions of TeXShop lock a source file which has not been opened for a while (I don't know what the time limit is).  In theory, I should be able to "unlock" such a file by clicking on the "locked" legend at the top of the file.  But if I have tried to open the source file using the synchronization from the PDF (i.e., command-click on text), then I get a blank window with just the name of the source file and the "locked" legend at the top.  When I click on that, I am informed that I cannot unlock the file, I can only copy it and edit that version.  On the other hand, if I then open that source file directly, I can unlock it, and with the appropriate project root at the top, I can use it to TeX the project.  At that point, I would expect the synchronization to work again, but I still get the locked behavior.

Is this a bug, or if not, is there a way for me to avoid this problem (other than going and opening all the files used in my book project with a certain frequency)?

Zbigniew Nitecki
Department of Mathematics
Tufts University
Medford, MA 02155

Office    (617)627-3843
Dept.    (617)627-3234
Dept. fax    (617)627-3966

More information about the macostex-archives mailing list