[OS X TeX] Bug in PDFKit

Victor Ivrii vivrii at gmail.com
Fri Apr 12 15:27:56 CEST 2013

On Fri, Apr 12, 2013 at 9:05 AM, Herbert Schulz <herbs at wideopenwest.com>wrote:

> On Apr 12, 2013, at 7:59 AM, Victor Ivrii <vivrii at gmail.com> wrote:
> > I found that if using hyperref I include in URL non-ASCII characters like
> >
> > \href{http://ru.wikipedia.org/wiki/Физико-математическая_школа_им._М._А._Лаврентьева_при_НГУ}{Physical
> Mathematical School at Novosibirsk State University}
> >
> > then resulting pdf link works in Adobe Reader/Acrobat (and in kpdf) but
> not in Preview or TeXShop which do not launch WebBrowser to access this
> link. Definitely bug in Apple PDF ToolKit
> Howdy,
> Could you supply a minimal but compilable example so we can see how you
> are including the cyrilic characters? Are you using UTF-8?

yes, I use UTF8 (in the source via TS preferences restarting TS each time
and creating new files for reliability) but it affects neither Adobe Reader
nor PDFKit based browsers (I tried several encodings to be sure).


again, it affects neither AR no Preview (or TS)

Also I tried
again, it affects neither AR no Preview (or TS)



returns an error

In the attached example second link works

Mathematical School at Novosibirsk State University}.

\href{http://ru.wikipedia.org/wiki/}{Russian wikipedia}.

PS The second URL always works (used for comparison)

PPS Checked with Skim (does not work, no surprise--it is Apple PDFKit based
as well), TeXWorks (works, it is poppler based)

Probably someone should file bug repport with Apple


Victor Ivrii, Professor, Department of Mathematics, University of Toronto
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/macostex-archives/attachments/20130412/319e9425/attachment.html>

More information about the macostex-archives mailing list