[OS X TeX] simpdftex can't find font, but pdflatex can

Herbert Schulz herbs at wideopenwest.com
Thu Mar 1 23:52:12 CET 2012

On Mar 1, 2012, at 4:29 PM, Nathan Sanders wrote:

> Like most of us, I've had various issues using fonts, but I've typically been able to resolve them myself.  But this one has me stumped.
> When I compile the following minimal example in TeXShop using "Typeset|TeX and DVI" (i.e., simpdftex), the compile fails, with the console error:
> /usr/texbin/dvips: ! Couldn't find header file: TengwarQuenya.ttf
> When I compile the minimal examples in TeXShop using "Typeset|Pdftex" (i.e., pdflatex), the compile succeeds perfectly, with the correct characters and no indication whatsoever that the location of the ttf file is in doubt.
> %%%%%%%%%% BEGIN MINIMAL EXAMPLE %%%%%%%%%%
> \documentclass{minimal}
> \usepackage[quenya]{tengwarscript}
> \begin{document}
> \Tparma\Ttinco\Tumbar\Tando
> \end{document}
> %%%%%%%%%% END MINIMAL EXAMPLE %%%%%%%%%%
> Here are some checks I've run at the command line, showing that TengwarQuenya.map is listed in updmap.cfg, and that it and TengwarQuenya.ttf are both in the correct location:
> % tail -1 `kpsewhich updmap.cfg`
> Map TengwarQuenya.map
> % kpsewhich TengwarQuenya.map
> /usr/local/texlive/2011/../texmf-local/fonts/map/local/dvips/tengwarscript/TengwarQuenya.map
> % kpsewhich TengwarQuenya.ttf
> /usr/local/texlive/2011/../texmf-local/fonts/truetype/local/tengwarscript/TengwarQuenya.ttf
> I've spent hours and hours moving files around, updmaping, texhashing, web-searching, and cursing, and the problem remains: simpdftex apparently can't find the font, but pdflatex can.
> This font has worked normally with simpdftex in the past: I discovered the problem while trying to re-compile a document that had compiled fine last spring with simpdftex (my normal compile routine).
> This is the first time I've tried to use this font since updating to TeXLive 2011, so apparently some path settings got messed up in the update, but I can't figure out why simpdftex and pdflatex would be looking in different places or how to fix it (assuming that is even the problem).
> Note also that simpdftex has no problem finding the TengwarQuenya.sty and .cfg files: both show up in the console with no console error (see console output below).
> Any ideas?
> Thanks!
> Nathan
> --
> Nathan Sanders
> Department of Linguistics
> Swarthmore College
> http://sanders.phonologist.org/
> ### This is /usr/texbin/simpdftex, Version 20070809
> ### /usr/texbin/latex Untitled.tex
> This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011)
> restricted \write18 enabled.
> entering extended mode
> (./Untitled.tex
> LaTeX2e <2011/06/27>
> Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
> rman-x-2011-07-01, ngerman-x-2011-07-01, afrikaans, ancientgreek, ibycus, arabi
> c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
> h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
> h, french, galician, german, ngerman, swissgerman, monogreek, greek, hungarian,
> icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, marathi, or
> iya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian, kurmanji,
> lao, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nynorsk, pol
> ish, portuguese, romanian, russian, sanskrit, serbian, serbianc, slovak, sloven
> ian, spanish, swedish, turkish, turkmen, ukrainian, uppersorbian, welsh, loaded
> .
> (/usr/local/texlive/2011/texmf-dist/tex/latex/base/minimal.cls
> Document Class: minimal 2001/05/25 Standard LaTeX minimal class
> )
> (/usr/local/texlive/2011/../texmf-local/tex/latex/local/tengwarscript/tengwarsc
> ript.sty (/usr/local/texlive/2011/texmf-dist/tex/latex/fp/fp-basic.sty
> `Basic Fixed Point Arithmetic',  Version 1.2d (C) Michael Mehlich             )
> (/usr/local/texlive/2011/texmf-dist/tex/latex/fp/fp-snap.sty
> `Fixed Point Snap Off',          Version 1.0a (C) Michael Mehlich             )
> (/usr/local/texlive/2011/../texmf-local/tex/latex/local/tengwarscript/quenya.cf
> g)) (./Untitled.aux) [1] (./Untitled.aux) )
> Output written on Untitled.dvi (1 page, 232 bytes).
> SyncTeX written on Untitled.synctex.gz.
> Transcript written on Untitled.log.
> ### /usr/texbin/dvips -R -Poutline  -o /tmp/altpdflatex.42594-1330640797/Untitled.ps Untitled.dvi
> This is dvips(k) 5.991 Copyright 2011 Radical Eye Software (www.radicaleye.com)
> ' TeX output 2012.03.01:1726' -> /tmp/altpdflatex.42594-1330640797/Untitled.ps
> /usr/texbin/dvips: ! Couldn't find header file: TengwarQuenya.ttf
> ### FAILED to generate /tmp/altpdflatex.42594-1330640797/Untitled.ps ()


It appears that you've installed the TengwarQuenya ttf version of the font but not the pbv version (if that even exists). As far as I know latex->dvips->ps2pdf (i.e., simpdftex) can't use ttf fonts while pdflatex can use them.

If the pfb files aren't available I'd bet that the tengwarscript package is designed to be used with pdflatex and loads the map file on its own with a pdftex command. If that's the case you shouldn't have installed the map file with updmap-sys.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list