[OS X TeX] biber error

Alan Munn amunn at gmx.com
Mon Jan 3 06:52:53 CET 2011

On Jan 2, 2011, at 9:00 PM, Alan Munn wrote:

> On Jan 2, 2011, at 8:02 PM, Herbert Schulz wrote:
>> On Jan 2, 2011, at 5:56 PM, Alan Munn wrote:
>>> Hi, since Herb mentioned biber in his most recent update of latexmk, I have a question about installing it.  I installed it using instructions from Joseph Wright's blog <http://www.texdev.net/tag/tex-live/>, by doing:
>>> tlmgr --repository http://tlcontrib.metatex.org/2010 install biber
>>> This installed it in /usr/local/texlive/2010/bin/x86_64-darwin/biber, which isn't in any of the normal paths, but that can easily be fixed.
>>> However, when I tried to run it I get the following error:
>>> e.g.
>>> $ /usr/local/texlive/2010/bin/x86_64-darwin/biber
>>> dyld: unknown required load command 0x80000022 Trace/BPT trap
>>> I get exactly the same error with a version downloaded directly from the biber web page:
>>> <http://biblatex-biber.sourceforge.net/>
>>> What's going on, and how can I fix it?
>>> This is on a Intel MacBook running 10.5.8
>>> Alan
>> Howdy,
>> Hmmm... It looks as though the biber you have is a 64bit version that will only run under OS X 10.6 so I'd expect a problem trying to run under 10.5. Looking at that repository there doesn't seem to be a version for Universal-Darwin so you may be out of luck.
> Oh well.  I guess I'll update to Snow Leopard then. (Although it would be nice if there was a correctly compiled binary around that would work on any OS.)

One more question.  Having upgraded to Snow Leopard, biber works, but it seems to be in a directory that isn't findable from the command line, since it's in /usr/local/texlive/2010/bin/x86_64-darwin/ .  What's the best way to fix this?


Alan Munn
amunn at gmx.com

More information about the macostex-archives mailing list