[OS X TeX] LaTeXiT producing blank output

Ken Mankoff mankoff at gmail.com
Thu Apr 7 07:48:13 CEST 2011


I'm posting here after not finding a solution on the texlive list.

I used to used texlive 2008 installed via fink, and LaTeXiT worked 
fine. I upgraded to texlive 2010 through the MacTex DMG installer, 
and LaTeXiT has stopped working. I did the upgrade a few months ago 
and have just launched LaTeXiT, so it could be something else, but I 
think it is tied to the fink_2008 -> GUI_2010 changes.

When I run LaTeXiT, it appears to run, but the display is blank.

In LaTeXiT, the paths are set correctly, and the tex it tries to 
compile is valid.

If I go to the tmp folder where the work is being done, I see 
latexit-1.tex and it contains the following valid code. If I run 
'pdflatex' on this, I get a valid PDF.

\usepackage{amssymb} %maths
\usepackage{amsmath} %maths
\pagestyle{empty} \begin{document}\begin{align*}

However, also in this folder is a file 'latexit-1.pdf', presumably 
the version of this document compiled by LaTeXiT. When I view this 
file (if I don't run pdflatex myself), I see 4 blank pages. Very 
strange. I can send the log file if that will help.

I've trashed the preference file for LaTeXiT and that did not help.

The log file diff from LaTeXiT and my running pdflatex look pretty 
much the same.

Any idea why valid latex compiled with pdflatex doesn't seem to work 
in LaTeXiT?



More information about the macostex-archives mailing list