[OS X TeX] Why this .ps file can not be viewed?

Maxwell, Adam R adam.maxwell at pnl.gov
Mon Mar 15 22:19:31 CET 2010

On 03/15/10 13:32, "Themis Matsoukas" <tmatsoukas at gmail.com> wrote:

> On Mar 15, 2010, at 3:56 PM, Leo wrote:
>> Hello all,
>> A .ps file exported from Emacs somehow can not be viewed in Preview.app.
>> If I run pstopdf in Terminal.app to convert it into .pdf file, it can
>> not be viewed either.
>> Any .ps expert can shed some light on this? I have attached a sample .ps
>> file.
> I am not a .ps expert but when I tried to open your file in Illustrator CS3 I
> got the message "The operation cannot be completed because of an unknown
> error," which seems to imply there is a problem with the ps file itself.

Likewise, I'm not a PS expert, but a similar topic came up recently on the
Skim mailing list.  The conclusion was that Apple's tools won't read the
Emacs' PS output, possibly because of fonts.

You can get something readable out of your PS file if you convert with
Ghostscript (ps2pdf) or PStill, although the latter gives a huge page.

More information about the macostex-archives mailing list