[OS X TeX] csv2latex

Alan Munn amunn at gmx.com
Sat Jan 30 16:46:36 CET 2010

On Jan 30, 2010, at 9:03 AM, Herbert Schulz wrote:

> On Jan 30, 2010, at 6:45 AM, Max Bichler wrote:
>> Dear Members,
>> I switched lately to snowleopard and one of the remaining problem  
>> is the nice csv2latex script for simple and effective  conversion  
>> of excel tables to latex.
>> I newly installed the necessary files, that means copying the  
>> csv2latex.rb into /usr/local/bin/, and setting up the macro in  
>> Texshop (which works), then  sudo texhash, restart, and still I get  
>> the Applescript error "sh: /usr/local/bin/csv2latex: No such file  
>> or directory" I tried it with an without the .rb extension, but got  
>> the same result. Did I overlook some detail? The FAQ paged did not  
>> tell about it.
>> Regards,
>> Max
> If you calling the script directly did you make sure that the script  
> was executable?
Hi, this is most likely the problem.  (Just make sure that if you've  
changed the name from csv2latex to csv2latex.rb you either reflect  
that change in the Applescript, or change it back so that the  
Applescript actually calls the correct execuatble.) As the author of  
csv2latex I'd like to improve the documentation, if possible. The  
documentation does mention to make sure the file is executable, but  
perhaps I should make this clearer by giving the exact commands to do  
so?   Would that have been helpful to you?


More information about the macostex-archives mailing list