[OS X TeX] Font installation problems

James A Mingo mingo at mast.queensu.ca
Fri Jan 8 05:56:27 CET 2010

I am trying to install the fonts

pilr8r    Caecilia-Roman         "TeXBase1Encoding ReEncodeFont" <8r.enc  <pilr8a.pfb
pilri8r   Caecilia-Italic        "TeXBase1Encoding ReEncodeFont" <8r.enc  <pilri8a.pfb
pilb8r    Caecilia-Bold          "TeXBase1Encoding ReEncodeFont" <8r.enc  <pilb8a.pfb
pilbi8r   Caecilia-BoldItalic    "TeXBase1Encoding ReEncodeFont" <8r.enc  <pilbi8a.pfb

I am running TeXLive2008 and I used the instructions in
Ch. II of Lehman's Font Installation Guide using

\input fontinst.sty

and the instructions on
for distributing the files. I then ran
sudo texhash
sudo updmap-sys --enable Map pil.map

I have successfully installed Adobe Type I fonts before, but
now I am stuck. LaTeX successfully produces a dvi file when
I compile


{\titlefont Test}


However when I run pdflatex I get
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag
1+360/600 --dpi 960 pilr8r
mktexpk: don't know how to create bitmap font for pilr8r.
kpathsea: Appending font creation commands to missfont.log.
!pdfTeX error: /usr/texbin/pdflatex (file pilr8r): Font
pilr8r at 960 not found

 ==> Fatal error occurred, no output PDF file produced!
When I run dvips I get a different but similar error message.

So it seems that some part of the fonts cannot be found. I

sudo updmap-sys --edit

to check if pil.map was there and at the end of the file
(updmap.cfg?) I found

Map pil.map

So it appears that the map file (located in
~/Library/texmf/fonts/map/dvips) was read. Is there some way
to diagnose the problem?

Thanks for any help.

Jamie Mingo

More information about the macostex-archives mailing list