[OS X TeX] Can someone please test this?

Berend Hasselman bhh at xs4all.nl
Thu Apr 8 20:11:03 CEST 2010

On 08-04-2010, at 19:54, Herbert Schulz wrote:

> Howdy,
> Well, I forgot to attache the file again... Sigh...
> <asymkrc>
> Good Luck,
> Herb Schulz
-------------- next part --------------
A non-text attachment was scrubbed...
Name: asymkrc
Type: application/octet-stream
Size: 1395 bytes
Desc: not available
URL: <http://tug.org/pipermail/macostex-archives/attachments/20100408/e89a3938/attachment.obj>
-------------- next part --------------

I tried your last attempt again.
Same error.
I think I found the problem/error.
The $pdflatex variable should look like this

$pdflatex = "pdflatex $TSUserCompileOptions --synctex=1 --file-line-error %O %S; " . 
                   "if [ -e %B.asy ] ; then " . 
                   "asy %B.asy; pdflatex $TSUserCompileOptions --synctex=1 --file-line-error %O %S; " .
                   "fi ";

I added a semi-colon after %S on the third line: bash regarded the "fi" as argument to pdflatex.
See attachment.

And now it works!



More information about the macostex-archives mailing list