[OS X TeX] elsarticle

Vincent Verfaille vvvvlists at gmail.com
Thu Oct 1 02:12:29 CEST 2009

On 30-Sep-09, at 7:52 PM, Themis Matsoukas wrote:

> This could be a bug in elsarticle.cls (in which case I apologize for  
> the OT nature of the question), or maybe there is a latex way around  
> it. The problem: I need to print an underscore inside a custom  
> command (\ead{}) of elsarticle.cls, the Elsevier latex package (for  
> those interested, \ead{} prints the author's email address and my co- 
> author's address has an underscore). I tried the following and they   
> failed:
> 1. \ead{ ... \url{_} ... }
> 2. \ead{ ... \_ ...}
> #1 generated errors in compilation; #2 compiled but instead of an  
> underscore I got the strange sequence  "_ _11_". Are there other  
> ways force an underscore?

It may indeed be a bug:
- using TexLive 2008 (lastest update, that uses: elsarticle  
2008/05/22, 1.0.1: Elsevier Science), I have the same error message as  
- using TeXLive 2009, it works fine... (it uses: elsarticle  
2009/09/17, 1.2.0: Elsevier Ltd)
Maybe you can simply update TeXLive, or download their latest style if  
not using it already...
Vincent Verfaille

More information about the macostex-archives mailing list