About "[OS X TeX] How to install MTPro II Fonts?"

Vic Norton vic at norton.name
Sat Mar 28 16:55:28 CET 2009

Hi Bruno,

Thanks for your suggestions. After I removed
and ran
   sudo mktexlsr
   sudo -H updmap-sys
   sudo -H updmap-sys --nohash --nomkmap --disable mtpro2.map
   sudo -H updmap-sys --enable Map mtpro2.map
everything seemed to compile perfectly with no error messages.

Out of curiosity I just downloaded a new copy of mtpro2fonts from  
PCTeX.com. It still has two mtpro2.map files in its texmf folder:

Unfortunately I still cannot compile the template file "MTPro2 LaTeX  
test.tex". Now I am getting the error message:

   (./MTPro2 LaTeX test.tex
   kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi  
600 mt2syt
   mktexpk: don't know how to create bitmap font for mt2syt.
   kpathsea: Appending font creation commands to missfont.log.
   !pdfTeX error: /usr/texbin/pdflatex (file mt2syt): Font mt2syt at  
600 not found

    ==> Fatal error occurred, no output PDF file produced!

Looking in texmf-local I can see three mt2syt files:
Aren't these the files pdfTeX is looking for?

This situation is totally perplexing. I don't need to use mtpro2  
fonts, but I hate to just throw $100 away. Maybe I'll empty texmf- 
local and try a complete reinstallation of mtpro2 fonts (without the  
obsolete texmf/dvips/mtpro2/mtpro2.map).



On Mar 28, 2009, at 7:35 AM, Bruno Voisin wrote:

> Hi Vic,
> Seeing the following on the OS X TeX list archive, a few indications:
>> The (texmf) elements of the package are in their proper places in
>> "/usr/local/texlive/texmf-local". When I run
>>   texmf-local$ sudo mktexlsr /usr/local/texlive/texmf-local
>>   texmf-local$ sudo updmap-sys --enable Map lucida.map
>> I get the message (well into the log)
>> !!! WARNING: Identical copy of used file for `mtpro2.map'
>>     exists in obsolete location
>>       /usr/local/texlive/2008/../texmf-local/dvips/mtpro2/mtpro2.map
>>     Please, consider removing this file.
>> I assume this message is referring to
>>    /usr/local/texlive/texmf-local/dvips/mtpro2/mtpro2.map
>> which is what I am trying to use---I think.
> You shouldn't, proper place is
> 	/usr/local/texlive/texmf-local/fonts/map/dvips/mtpro2/mtpro2.map
> The warning seems to indicate you've got two files mtpro2.map, one  
> at the proper location texmf-local/fonts/map/dvips/ (or at ~/Library/ 
> texmf/fonts/map/dvips/ from a previous attempt in ~/Library/texmf)  
> and the other at the obsolete location texmf-local/dvips/. You  
> should remove the second, and make sure the first is indeed present  
> and inside texmf-local/fonts/map/dvips/.
> Generally, unless you've installed something willingly there (like  
> dvips preamble files for achieving some special PostScript effects),  
> there should be nothing inside /usr/local/texlive/texmf-local/dvips  
> apart from the empty "local" folder created (I believe) by MacTeX  
> upon install.
> After doing this, you must first update TeX's file search database  
> with
> 	sudo mktexlsr
> then you can use kpsewhich to check that the proper mtpro2.map is  
> indeed found and used, with
> 	kpsewhich mtpro2.map
> which should return /usr/local/texlive/texmf-local/fonts/map/dvips/ 
> mtpro2/mtpro2.map.
> Then, running
> 	sudo -H updmap-sys
> should be enough, since you seem to have already the entry
> 	Map mt-yy.map
> in /usr/local/texlive/2008/texmf-config/web2c/updmap.cfg (judging by  
> the warning message you get, which indicates updmap-sys looks for  
> mtpro2.map). The "-H" option to updmap-sys implies ~/Library/texmf  
> isn't read, so that any leftover files you would have from a  
> previous installation not fully cleaned up won't pollute by accident  
> the operation of updmap-sys.
> If that's still not enough, then you might try Pete's solution
> 	sudo -H updmap-sys --nohash --nomkmap --disable mtpro2.map
> 	sudo -H updmap-sys --enable Map mtpro2.map
>> At the end of the log I see
>>    With this release, the search paths for map files have been  
>> changed
>>    and we have found that some files exist in the new path as well as
>>    in the obsolete path.
>> As far as I can tell the obsolete path
>>    /usr/local/texlive/texmf-local/dvips/mtpro2/mtpro2.map
>> is what my system thinks is an obsolete path.
> Obsolete it is indeed.
>> In any case, when all is said and done I can't even start to compile
>> the template file "MTPro2 LaTeX test.tex". I am told
>>   kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 4+0/600 --dpi
>> 2400 mt2exf
>>   mktexpk: don't know how to create bitmap font for mt2exf.
> That's normal error message, indicating updmap-sys has not been able  
> to find the information in mtpro2.map and include it in the map files
> 	/usr/local/texlive/2008/texmf-var/fonts/map/dvipdfm/updmap/ 
> dvipdfm.map
> 	/usr/local/texlive/2008/texmf-var/fonts/map/dvips/updmap/ps2pk.map
> 	/usr/local/texlive/2008/texmf-var/fonts/map/dvips/updmap/psfonts.map
> 	/usr/local/texlive/2008/texmf-var/fonts/map/pdftex/updmap/pdftex.map
> used by (x)dvipdfm(x), ps2pk, dvips and pdf(la)tex respectively.  
> Because that info is missing from these map files, dvips etc. think  
> the fonts are MetaFont fonts in source (.mf) format and call the  
> mktexpk script to create bitmap versions in .pk format.
> Hence dvips or pdftex, instead of using the PS font associated with  
> mt2exf.tfm, tell mktexpk to process the non-existing file mt2exf.mf  
> which it doesn't find, generating the above message.
>> Any suggestions would be appreciated,
> Hope the above helps. Feel free to forward this message to the OS X  
> TeX list if you think it appropriate.
> Bruno

More information about the macostex-archives mailing list