[OS X TeX] Wrong latex getting used.

Herbert Schulz herbs at wideopenwest.com
Tue Mar 3 03:31:56 CET 2009

On Mar 2, 2009, at 7:50 PM, Rolf Turner wrote:

> I sent the following message to the texhax mailing list earlier
> today, and it was suggested to me that I try *this* list.  So
> here goes:
> This is really more a problem with Mac OS X than with latex, ...
> But I don't know where else to turn and this list is usually very
> helpful.  Said he hopefully.
> Recently I unwisely did a re-install of LaTex on my Imac --- using,
> I *think* ``sudo fink install latex''.  Can't even remember why I
> did this. :-(
> Ever since, things that used to work now don't.
> This morning I tried to process a powerdot presentation to which
> I had made some slight adjustments, and got errors in respect of
> xkeyval --- it complained that I had requested a newer version
> of xkeyval than was available, and then threw an error about
> an undefined control sequence.  I can give further details if
> these are relevant, but I don't think so.
> Upon investigation I found that the xkeyval package in
> 	/sw/share/texmf-dist/tex/latex
> was indeed out of date, and the latex that gets used is in
> /sw/bin.  But there is a perfectly up-to-date xkeyval in
> 	/usr/local/texlive/2008/texmf-dist/tex/latex
> which seems to be what is pointed to by the symbolic links inside
> 	/Library/TeX/Distributions
> I would have thought that this last would be what would get used
> by latex by default under Mac OSX (I must confess that I really
> don't understand the convolutions that Mac OSX superimposes upon
> Unix) but it seems not.  As I said above, /sw/bin/latex seems to
> get used and this seems to draw upon the out-of-date stuff in
> /sw/share/texmf-dist/tex/latex.
> There is a /usr/texbin that appears automagically in my path,
> and this seems to point at the right thing.  I tried setting
> my path explicitly in my .cshrc file, putting /usr/texbin ahead
> of /sw/bin.  But blow me down, when I echo my path afterwards,
> /sw/bin and /sw/sbin are always the first two entries in the
> path, no matter what I tell it.  (I *hate* it when computers refuse
> to do what you tell them!)  And the wrong latex still gets
> used.
> How can I get the /sw/bin/latex out of the way?  Does anyone out there
> understand Mac OSX enough to help me?
> Thanks.
> 	cheers,
> 		Rolf Turner


What does

echo $PATH

executed in Terminal return?

There is usually a problem with the PATH so that the wrong fle gets  
executed. The order of the directories in the PATH variable makes a  
difference since the first directory that has the executable is the  
one that will be used by the system.

Also, what program are you using to compile; is it a GUI program or  
through the Terminal?

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list