[OS X TeX] BibTeX-Problem on Mac: couldn't open style file/ couldn't open database file

Peter Dyballa Peter_Dyballa at Web.DE
Thu Oct 30 10:43:47 CET 2008

Am 30.10.2008 um 01:14 schrieb Matthias Geissbuehler:

> no it still doesn't work... same error:  :-(

Did you install only a basic Mac TeX? This could explain why  
kpsewhich can't find the BiBTeX STyle file – because it's not  
included (what I don't know for sure), but since you have all these  
shelah files in one directory, bibtex should find listb.bib – except  
it's a follow-up error! So it looks as if bibtex has problems. Do you  
have any environment variables defined? The command "env | egrep 'TEX| 
BIB'" would reveal them ...

Finally you could check with these commands whether your system is  
set up correctly:

	kpsewhich -show-path=bst | tr ':' '\n' | sort
	kpsewhich -show-path=bib | tr ':' '\n' | sort

They should produce this


or that output:


The output lists the directories where BST or BIB are found by TeX.  
Those entries starting with !! are not really searched, files in  
these system areas are only looked-up in "hash files." The final //  
stands for recursively search (or look-up) all sub-directories. The  
single line "." stands for "here," i.e., the directory where the file  
being TeX'ed lies.

Can you check

Mit friedvollen Grüßen


Reisen bildet - vor allem Staus auf Autobahnen.	(Michael Schiff)

More information about the macostex-archives mailing list