[OS X TeX] BibTeX-Problem on Mac: couldn't open style file/ couldn't open database file

Matthias Geissbuehler matthias.geissbuehler at epfl.ch
Thu Oct 30 09:58:06 CET 2008

Hello everyone,

Wow: what a great mailinglist! thanks to everyone for their kind  

I just in this very moment found out what the problem really is:
As mentioned before, the only thing that I recently did that could  
affect my Latex-distribution, was installing LyX (in order to help out  
a friend how to use it).
Now there is no problem with having them in parallel as such, but I  
wanted my LyX distribution to be in English which is why I needed to  
change this file:
according to the LyX-Wikipage http://wiki.lyx.org/Mac/Environment

what I didn't pay attention in the beginning, was that in their  
exemplary .plist-file they have two lines that specify the default  
location for .bst and .bib files!
their exemplary file can be found here: http://wiki.lyx.org/uploads/LyX/MacOSX/environment.plist

I deleted those first keys and no everything is fine again and my  
bibtex works fine.

I'm sorry to have disturbed you with this, I will put a line in the  
LyX-Wiki, because I consider this rather misleading to put an  
exemplary-plist file in their Wiki that makes your usual bibtex to  
stop working!

Anyway: have a nice day everyone and thanks for your help!


> From: Herb Schulz
> Do you have older TeX distributions? Please go to System Preferences-
>  >TeX Distribution and see what distribution is active.
I had only one distribution (2007) active when the error happened for  
the first time. Then I upgraded to the newest, so NOW I have two  
distributions, and only 2008 which is active.

> Also what does
> the command
> echo $PATH
> return?

> Also, what does
> which bibtex
> return in Terminal?

> I'm wondering whether the the full MacTeX is really installed
As far as I know I did indeed install the full MacTeX-distribution.

> From: Justin C. Walker
> A really stupid question, just to clear something up: in what
> directory did you put the .bst file?
To be honest I have never thought about this before, since the TeX- 
Live distribution does organize the default .bst files on its own. The  
one used for this simple example is a standard .bst file.

Matthias Geissbuehler
BM 5.138
Station 17
CH-1015 Lausanne

+41 21 693 77 70 (office)
+41 21 693 78 20 (fax)
matthias.geissbuehler at epfl.ch

Am 30.10.2008 um 02:58 schrieb David Watson:

> On Oct 29, 2008, at 1:17 PM, Matthias Geissbuehler wrote:
>> Hello everyone,
>> I'm a rather long term user of Latex on Mac OS X but today I ran
>> into a problem that I couldn't figure out how to resolve this.
>> In short the problem is that I can't get my BibTeX to work anymore.
>> Here is what happens:
>> 1) To limit possible reasons I went for the simplest example using
>> a .bib file. I found one here:
>> http://shelah.logic.at/eindex.html (three files)
>> 2) I ran Latex (2x) over the file and then Bibtex (1x) (from within
>> TeXShop). Here is the output that I get:
>> ---
>> This is BibTeX, Version 0.99c (Web2C 7.5.7)
>> The top-level auxiliary file: lpaper.aux
>> I couldn't open style file unsrt.bst
>> ---line 7 of file lpaper.aux
>> : \bibstyle{unsrt
>> :                }
>> I'm skipping whatever remains of this command
> I ran `find /usr/local/texlive -name "unsrt.bst"` on the command line
> and found the following with an extremely fresh installation of Mac OS
> X 10.5.x updated to 10.5.5 with MacTeX 2008:
>     /usr/local/texlive//2008/texmf-dist/bibtex/bst/base/unsrt.bst
> Note that I have never tried to update my TeXLive 2008 installation
> using TeX Live Manager.
>> I couldn't open database file listb.bib
>> ---line 8 of file lpaper.aux
>> : \bibdata{listb
>> :               ,mybib}
>> I'm skipping whatever remains of this command
>> I found no database files---while reading file lpaper.aux
>> I found no style file---while reading file lpaper.aux
>> (There were 4 error messages)
>> ---
>> 3) To check if it has something to do with my configuration, I asked
>> my brother to compile the same three files for me on his Mac (same
>> distribution) and it did work without problems! (with exactly the
>> same commands)
>> 4) My first attempt to resolve this was by just re-installing the
>> newest MacTex distribution: TeXLive-2008. -> I did so, and I still
>> get the same error message.
>> I'm certain that my distribution did work before (with BibTex as
>> well). The only thing I can think of for the moment, is that I
>> installed LyX for Mac recently (in order to help out a friend how to
>> use it...).
> Perhaps you should run `which kpsewhich` in your terminal.
> Or even `echo $SHELL`.
> Let us know your results.
>> Any help with this would be really appreciated!
>> Thanks a lot!
>> Mat
> <smime.p7s><ATT00001.txt>

More information about the macostex-archives mailing list