[OS X TeX] MinionPro Package with LiveTeX

Matthew Braham m.braham at rug.nl
Sun Feb 17 00:53:10 CET 2008

Dear Peter

Apologies, but if you mean that what I am doing is "quatsch", then I  
accept. I am not lying. What happened is as follows: I installed  
MnSymbol and it worked. After many attempts to get MinionPro to work  
I decided that maybe something has gone wrong in the system. In fact,  
I even managed to get both working on MiKTeX. You see, I have been a  
Windows user for many years and am also new to tex.  So as is usual  
with Windows apps, if nothing works uninstall and start again.

As for Time Machine: I don't have it, I'm have 10.4.

I currently have the files in:


The map file is MinionPro.map and is currently located in:


I attach the proof below. What is interesting is that in the error  
message it is written 'Minion.map'. Where is this coming from because  
it is MinionPro.map.

I also send proof of the location of the tfm files.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Picture 1.png
Type: image/png
Size: 201778 bytes
Desc: not available
URL: <http://tug.org/pipermail/macostex-archives/attachments/20080217/91acdd94/attachment.png>
-------------- next part --------------

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Picture 2.png
Type: image/png
Size: 220624 bytes
Desc: not available
URL: <http://tug.org/pipermail/macostex-archives/attachments/20080217/91acdd94/attachment-0001.png>
-------------- next part --------------

On Feb 16, 2008, at 23:45 PM, Peter Dyballa wrote:

> Am 16.02.2008 um 20:44 schrieb Matthew Braham:
>> I originally had it all in /usr/local/texlive/texmf-local/ but it  
>> did not work.
> Either this sentence or your last sentence I am citing is a lie.  
> Which one is it? And why did you destroy your working TeX system?  
> Can't you use Time Machine to restore the working setup?
> /usr/local/texlive/texmf-local is the proper branch to install  
> local additions. After you've added something or you've renamed  
> something, it is necessary to run
> 	sudo texhash
> When you move MAP file fragments around it is recommended (usually  
> one isn't updating the MAP files every day or hour) to run
> 	sudo updmap-sys --syncwithtrees
> afterwards. And if the MAP fragments in the personal TeX are  
> changed, then it's recommended to also run
> 	updmap --syncwithtrees
>> I have moved it now to the location you suggested:
>> /Users/Matthew/Library/
>> I have run the command and get:
>> !!! ERROR! The map file `Minion.map' has not been found at all.
>>     Either put this file into the right place or remove the
>>     reference from the configuration file. An automatic way
>>     to disable unavailable map files is to call
>>       updmap --syncwithtrees
>>     For manual editing, call
>>       updmap --edit
>> I'm lost, because the MnSymbol installation worked first time!
> Is the MAP file fragment really Minion.map with a capital M? Or is  
> it MinionPro.map?
> The directory /usr/local/texlive/texmf-local/fonts should have at  
> least these directories:
> 	drwxr-xr-x    3 root  wheel   102  3 M?r  2007 map
> 	drwxr-xr-x   61 root  wheel  2074 30 Jun  2007 tfm
> 	drwxr-xr-x   10 root  wheel   340 30 Jun  2007 type1
> 	drwxr-xr-x   11 root  wheel   374 30 Jun  2007 vf
> MAP file fragments belong in /usr/local/texlive/texmf-local/fonts/ 
> map/dvips into a sub-directory "MinionPro" or such, that gives a  
> hint to which package or font family these MAP file fragments belong.
> The same name should be used in /usr/local/texlive/texmf-local/ 
> fonts/tfm to receive the TFM files, in /usr/local/texlive/texmf- 
> local/fonts/type1 to receive the PostScript Type 1 font files, in / 
> usr/local/texlive/texmf-local/fonts/vf to receive the VF files.
> According to the saved output file from 'kpsewhich -debug 8  
> MinionPro-Regular-Base-ab.tfm' from earlier today the tree /usr/ 
> local/texlive/2007/../texmf-local/fonts/tfm is not searched but  
> looked up from its ls-R hash file for TFM files. (The private tree / 
> Users/Matthew/Library/texmf/fonts/tfm is really searched.) MAP file  
> fragments in the /usr/local/texlive/2007/../texmf-local/fonts/map  
> tree are are looked up too. (The private tree /Users/Matthew/ 
> Library/texmf/fonts/mapm is really searched.) The notation ``..??  
> in a pathname stands for "one directory level higher" or, in our  
> case, ``2007/..?? is substituted with nothing or ``/usr/local/ 
> texlive/2007/../texmf-local?? is substituted with ``/usr/local/ 
> texlive/texmf-local??. So kpsewhich is working fine and obviously  
> the particles of the MinionPro package are (were) not correctly  
> installed. Proof: they were not found in their proper places  
> according to the TeX configuration file.
> --
> Greetings
>   Pete      <\
>              _\     O  _
>             |o \  _\\_/-\='
> _____________(_)|-(_)  (_)___________________________________
> -------------------------- Helpful Info --------------------------
> TeX FAQ: http://www.tex.ac.uk/faq
> List Reminders and Etiquette: http://www.esm.psu.edu/mac-tex/list/
> List Info: http://email.esm.psu.edu/mailman/listinfo/macosx-tex
> List Archive: http://tug.org/pipermail/macostex-archives/
> Mac-TeX Website: http://www.esm.psu.edu/mac-tex/


Faculty of Philosophy
University of Groningen
Oude Boteringestraat 52
9712 GL Groningen
The Netherlands

T: +31 50 363-6948
F:  +31 50 363-6160

Lindenstr. 13a
D-21521 Aum?hle

T: +49 4104 2739

More information about the macostex-archives mailing list