[OS X TeX] Getting started with tlmgr

Herbert Schulz herbs at wideopenwest.com
Fri Dec 5 16:45:11 CET 2008

On Dec 5, 2008, at 9:20 AM, Gary L. Gray wrote:

> Hi Herb.
> You didn't cause any problems for me, I did. :-)
> I used Migration Assistant to move to a new MacBook Pro a couple of  
> weeks ago and I thought it brought TeX over perfectly since  
> everything *seemed* to work. Unfortunately, I hadn't tried anything  
> TeX-related in the Terminal until last night. When it didn't work, I  
> wasn't sure what was happening, but it was late and I didn't want to  
> wait to download 1.15 GB from home to get the MacTeX installer. I  
> just downloaded it, re-installed MacTeX and all is well in the  
> Terminal.


Unfortunately I've had problems with symlinks when using Migration  
Assitant although most things are carried over amazingly well. I  
always (well, I don't get new systems that often) re-install anything  
that isn't in /Applications/ just to make sure it's all there.

> With that said, I just tried the tlmgr commands you posted last  
> night and here is what I got:
> loon:Dynamics gray$ sudo tlmgr option location http://mirror.ctan.org/systems/texlive/tlnet/2008
> Password:
> Setting default installation source to http://mirror.ctan.org/systems/texlive/tlnet/2008 
> !
> loon:Dynamics gray$ sudo tlmgr update bin-texlive texlive.infra
> update: bin-texlive (first remove old, then install new)
> remove: bin-texlive
> remove: bin-texlive.universal-darwin
> running post remove action for bin-texlive
> install: bin-texlive
> install: bin-texlive.universal-darwin
> running post install action for bin-texlive
> update: bin-texlive done
> update: texlive.infra (first remove old, then install new)
> install: texlive.infra
> running post install action for texlive.infra
> update: texlive.infra done
> running mktexlsr
> mktexlsr: Updating /usr/local/texlive/2008/../texmf-local/ls-R...
> mktexlsr: Updating /usr/local/texlive/2008/texmf/ls-R...
> mktexlsr: Updating /usr/local/texlive/2008/texmf-config/ls-R...
> mktexlsr: Updating /usr/local/texlive/2008/texmf-dist/ls-R...
> mktexlsr: Updating /usr/local/texlive/2008/texmf-doc/ls-R...
> mktexlsr: Updating /usr/local/texlive/2008/texmf-var/ls-R...
> mktexlsr: Done.

This all looks ok!

> loon:Dynamics gray$ tlmgr update --list
> tlmgr: installation location http://mirror.unl.edu/ctan/systems/texlive/tlnet/2008
> Can't locate object method "option" via package "TeXLive::TLPDB" at / 
> usr/texbin/tlmgr line 1091, <RETFH> line 116086.
> Something went bad at the end -- do you know what that might be?
> All the best,
>  Gary

This sounds like a problem with one of tlmgr's modules. I think your  
best bet is to use the shell script, update-tlmgr-latest.sh, you can  
get from the Disaster Recovery section on <http://www.tug.org/texlive/tlmgr.html 
 >. This will download and install all of the tlmgr files. If you put  
it on the Desktop you should run

cd ~/Desktop
chmod a+x update-tlmgr-latest.sh
sudo ./update-tlmgr-latest.sh

and enter your admin password. There may be some prompts generated by  
the script; I haven't used it. Maybe I should add a section on this to  
the document.

I'm already re-writing the document so that a fixed server can be set  
rather than the load sharing mirror which should be used once the  
updated tlmgr is in use.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list