[OS X TeX] Getting started with tlmgr

Axel E. Retif axel.retif at mac.com
Fri Dec 5 10:59:38 CET 2008

On  4 Dec, 2008, at 21:55, Luis Vitorio Cargnini wrote:

> Hash: SHA1
> Re-install again. Last time this occurs with me, I did that to  
> solve, 2 months ago.
> Now it is working fine

Right. About two weeks ago, the same happened to me, but the weird  
thing is this: I updated my Ubuntu distribution without a problem;  
immediately after that, I tried to update my Macbook, and it wreaked  
havoc! with messages like

> Installation of new version of <such and such package> did fail,  
> trying to unwind!

Everything was useless ---binaries weren't found, etc.; recovery  
methods didn't work... Long story short, I reinstalled and updated  
again without a single problem! Afraid something was wrong with Mac  
updates, before updating my desktop I tared TL 2008, then did the  
update... and everything worked fine!

But definitely, Schulz's advice is the way to go:

sudo tlmgr option location http://mirror.ctan.org/systems/texlive/tlnet/2008

sudo tlmgr update bin-texlive texlive.infra

sudo tlmgr update --all

Something might go wrong ---like it happened to me in one of three  
updates (a momentary server error?)---, but it's the proven and TUG  
recommended procedure.



More information about the macostex-archives mailing list