Alain Schremmer schremmer.alain at gmail.com
Wed Aug 13 05:49:13 CEST 2008

On May 23, 2007, at 2:55 PM, Aaron Jackson wrote:

> Aquaterm is a small app that other programs can use to display  
> graphical output.  Gnuplot does not require Aquaterm, however  
> installing it is highly recommended.  Gnuplot has to display plots  
> somehow, so it uses Aquaterm if it is available, if not it can use  
> X11.  If you never want to see the plots (within gnuplot itself),  
> then gnuplot can save them directly to disk as LaTeX, pdf, eps,  
> png,... files, which means, in this case, that X11 and Aquaterm are  
> not needed.
> Gnuplot is very easy to compile.  A simple
> ./configure
> make
> make check
> make install
> should do the trick (assuming that you have Aquaterm installed,  
> otherwise skip the make check step).  If the configure stops for  
> any reason (perhaps a missing readline lib if I remember), you can  
> disable the check that is failing (type ./configure --help for  
> options).  You wont need it anyway if you are not directly using  
> gnuplot.

As you may, or may not, recall, I am install-challenged.

A couple of years ago, with the off list help of Bongard, I installed  
gnuplot with Aquaterm and Qgfe which worked nice but, at the time, I  
was just getting prepared. Now that I need to use it, I have gone  
from 10.3 to 10.4 I downloaded and "installed"


—QtMac410-Tiger-Mini (in the Qt4.1.0_MINI(MacOSX 10.4.x) folder there  
is no application.)

—Qgfe-1.0 (But I think that what I installed, xm1math, is only a  
library as I couldn't find the application anywhere. It says  
somewhere that the API is in gnuplot.

But then, in the terminal, I got:

Last login: Tue Aug 12 09:31:09 on console
Welcome to Darwin!
You have mail.
juju-gpadnom(*):~ gpadnom$ which gnuplot
juju-gpadnom:~ gpadnom$ echo $PATH
juju-gpadnom:~ gpadnom$ export PATH=/usr/local/bin:$PATH
juju-gpadnom:~ gpadnom$ gnuplot
dyld: Library not loaded: /usr/local/lib/libaquaterm.1.0.0.dylib
   Referenced from: /usr/local/bin/gnuplot
   Reason: image not found
Trace/BPT trap

I did find the following alias:

MacIntosh HD > Users > gpadnom > libaquaterm.1.0.0.dylib

but had no idea what to do after that. I then went to the web and  
found that this seemed to be well-known, e.g.



but I didn't know enough to understand and use the rather sparse  
advice, some of which seemed a bit dubious in any case.

I spent the whole day today googling for some help but didn't find  
anything other than, here and there, some smart aleck advice such as  
"file a bug report with Apple". (I even tried other things such as  
jPlot and GnuplotGUI but wasn't able to make either work. Something  
about no being able to find the path to gnuplot.)

Any kind of help would be most appreciated.


(*) As I was installing 10.4, Apple started to get really nosy so,  
rather annoyed, I gave it gpadnom (phonetically = I have no name) as  
my name.

More information about the macostex-archives mailing list