[OS X TeX] Configuring man pages

Chris Goedde cgg.lists at gmail.com
Tue Aug 5 16:44:28 CEST 2008

On Aug 5, 2008, at 2:54 AM, Bruno Voisin wrote:

> Le 5 août 08 à 00:21, Richard Koch a écrit :
>> On Aug 4, 2008, at 3:13 PM, David Watson wrote:
>>> [...]
>> MacTeX configures MANPATH as part of the installation, and uses the  
>> Laurens-Wierda TeX Distribution structure so the correct man pages  
>> will be shown depending on your active distribution. The method of  
>> configuring MANPATH changed in Leopard, but this will work when TeX  
>> Live 2008, and thus MacTeX-2008, is released.
> In other words, until MacTeX-2008 is released, you can solve your  
> problem by applying the Leopard TeX fix available from <http://www.uoregon.edu/~koch/ 
> >.
> See the explanations at <http://www.uoregon.edu/~koch/LeopardTeXFix.rtf 
> >, in particular:

Looks like I spoke to soon. I ran the Leopard TeX fix and rebooted,  
but I still can't access the man pages from the terminal. If I look  
in /etc/manpaths.d and /etc/paths.d, I see:

-rw-r--r--  1 root  wheel  52 Aug  5 09:13 TeX
-rw-r--r--  1 root  wheel  13 Sep 23  2007 X11

So the fix seems to have installed the right parts. (BTW, the original  
permissions on the TeX file were -rwxr-xr-x, I changed them to match  
the X11 file permissions. It didn't work with either the original or  
the new permissions.) If I run manpath from the terminal, the output is:


Any suggestions on fixing/troubleshooting this is appreciated. BTW, I  
can't run latex from the terminal either (not that I ever do that).


More information about the macostex-archives mailing list