[OS X TeX] fonts in leopard

Robert Clare Robert.Clare at ucr.edu
Tue Nov 20 19:45:20 CET 2007

I, like many others, have had enormous problems with Latex Equation  
Editor and Latexit under Leopard.  They were not rendering equations  
correctly, and, once used, Preview would display any TeX PDF file  
incorrectly.  The 'standard' trick of deleting the font caches, both  
in ~/Library/Caches as well as in the /var/folders hierarchy have  
failed to work for me.  Rebooting was the way out (logging out might  
have worked as well; if I have to log out I might as well reboot...),  
which made it clear to me that something bad was being cached and that  
something bad was getting cleared on reboots.

However, I just tried using the old version of Latexit, version  
1.14.3, and lo and behold!  It seems to work!  At least it formats  
nicely, and I can simply drag the resulting pdf into Keynote, and all  
is OK.  And Preview doesn't get upset.  I kind of miss my old friend  
Latex Equation Editor, as I knew its quirks, but Latexit is a valid  
replacement.  Version 1.14.4, however, displayed the same font  
weirdness as Latex Equation Editor.

This is all very bizarre to me, and it would really be nice if some  
font wizard could try to find the root of the strange behavior that I  
and many others have been seeing.  But at least for the time being, I  
am much happier with Leopard than I was yesterday!

Bob Clare

More information about the macostex-archives mailing list