[OS X TeX] Error: I can't write on file '(name)'

Herbert Schulz herbs at wideopenwest.com
Fri Mar 23 14:19:23 CET 2007

On Mar 22, 2007, at 11:40 PM, Alain Schremmer wrote:

> (3) But I am a bit puzzled by the fact that the TeXShop I just  
> installed still has teTeX in the Path settings. So it may be that  
> the fact that I had not uninstalled the old installation worked in  
> my favor.


I don't think there were any changes made to TeXShop 1.4.3 (needed  
for Panther) to automatically ``fix'' the path.

> (4) Indeed, when I tried to do the same minimal installation,  
> TeXShop & gwTeX on my wife's mac (also with 10.3.9), it immediately  
> complained that it couldn't find pdflatex and then something about  
> teTeX missing. Changing teTeX to gwTeX in TeXShop's Path settings,  
> though, didn't work.

The (pdf)TeX Path setting in TeXShop->Preferences->Engine, with  
either gwTeX or TeXLive, should be set to


once and for all. Then, when you change the active distribution  
(there is now a System Preference Pane for dong this) nothing will  
have to change in TeXShop's (or BibDesk's, or LaTeXiT's) Preferences.

Good Luck,

Herb Schulz
(herbs at wideopenwest.com)

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the macostex-archives mailing list