[OS X TeX] Error: I can't write on file '(name)'

Alain Schremmer Schremmer.Alain at gmail.com
Thu Mar 22 20:55:11 CET 2007

Bruno Voisin wrote:

> Le 22 mars 07 à 17:20, Alain Schremmer a écrit :
>> (1)  I tried to install nano. After I downloaded it, I got the  usual 
>> incomprehensible (for me) stuff on the terminal, the short of  it is 
>> that it can't install nano.
> No need to install anything, it's already there, part of OS X:
> theo0mc234:~ brunovoisin$ which pico
> /usr/bin/pico
> theo0mc234:~ brunovoisin$ which nano
> /usr/bin/nano
> theo0mc234:~ brunovoisin$ cd /usr/bin
> theo0mc234:/usr/bin brunovoisin$ ls -l
> total 287592
> [...]
> -rwxr-xr-x    1 root  wheel    116752 Mar 21  2005 nano
> [...]
> lrwxr-xr-x    1 root  wheel         4 Aug 24  2006 pico -> nano
> [...]
> Sorry, I should have been more specific.

Well, *I* am sorry: this is not specific enough.

When I open the terminal,
Welcome to Darwin!
tcsh: /sw/bin/init.csh: No such file or directory.
[Alain:~] alainsch%
When I type
sudo pico /usr/local/texlive/2007/texmf/web2c/texmf.cnf
I get
   UW PICO(tm) 2.5    File: .../texlive/2007/texmf/web2c/texmf.cnf  Modified
in reverse video and, at the bottom, [New File]
and a list of commands such as ^R read file but when I type ^R and 
Return nothing happens


>> (4) As per Dyballa's terminal-free approach, I opened texmf.cnf  with 
>> SubEthaEdit.
>> However, there is no openout, openin, etc in texmf.cnf
> That's normal if you're speaking of gwTeX and opened /usr/local/gwTeX/ 
> texmf.cnf: this texmf.cnf contains only changes to the standard setup  
> defined deeper in the gwTeX tree, in /usr/local/gwTeX/texmf/web2c/ 
> texmf.cnf taken verbatim from TeXLive.
> gwTeX uses this standard setup, adding to it the modifications  
> specified in /usr/local/gwTeX/texmf.cnf. Because gwTeX doesn't modify  
> openout_any and openin_any by default, it's normal there is no  
> mention of these variables inside /usr/local/gwTeX/texmf.cnf.
> Meaning that you need to *add* to /usr/local/gwTeX/texmf.cnf the  
> following line:
> openout_any = r
> openout_any = a

Where do I add that line?

> Actually it's rather me who's at sea: I just purchased the DVDs of  
> season 2 of The Outer Limits last weekend, and watched this episode  
> in which planet Mars is covered with a sea of sand inside which  
> hostile marine creatures are hiding like sharks, unsuspected, waiting  
> to make their lunch of astronauts foolish enough to wander on this  
> sand. Watching this was like a trip to childhood (when I first saw  
> this episode), almost bringing tears to my eyes...

Not to my childhood but I should try that on my grand sons (12 and 14)

And here is the latest development:

When, at Goedde's request, I tried to copy the console, I couldn't 
select anything so I hit X and then the file got typeset!!!!!

Very puzzled regards to all

Best regards

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the macostex-archives mailing list