[OS X TeX] A question from a new member

Alain Schremmer Schremmer.Alain at gmail.com
Mon Oct 16 22:36:27 CEST 2006

Alan Munn wrote:

> At 2:43 PM -0400 10/16/06, Alain Schremmer wrote:
>> Paul Vickers wrote:
>>> I've been using TeXshop for about 2 years now and never noticed that 
>>> 'tags' button - what a time saver, D'oh! also realised I didn't have 
>>> CocoAspell installed. Gaarrgghh!
>>> All fixed and even happier now.
>> Same here except that when I got to install on 10.3.9, OS X said 
>> Failed to compile/configure aspell6-en-6.0-0 dictionary. Oh well.
> Here are two replies (one from Pete and one from myself) on solving 
> the aspell problem.  -Alan
> At 7:24 PM -0400 8/27/06, Alan Munn wrote:
>> At 10:39 PM +0200 8/27/06, Peter Dyballa wrote:
>>> Am 27.08.2006 um 21:21 schrieb Alan Munn:
>>>> 1. Cocoa aspell
>>>> I downloaded the new Intel version of Cocoa aspell and it seemed to 
>>>> have installed ok.  However, when I open the Spelling preference 
>>>> pane it says that the English dictionary failed to compile  because 
>>>> I don't have sufficient access privileges. There is a vague note in 
>>>> the documentation about some users reporting problems if their 
>>>> default shell is tcsh (which is my case, but there is no further 
>>>> help on this.)
>>> The workaround: create an admin user with bash and re-install!
>> Actually this is only part of the problem (or maybe even unrelated.) 
>> I did as you suggested and still got the same problem.  It seems that 
>> cocoaAspell sets the user permissions of its directory to the the 
>> username of the UID 501 and the group permission to 501.  Since I was 
>> using a different admin account, when it tried to build the 
>> dictionaries, it couldn't.  When I changed the permissions to my user 
>> id and admin as the group, it worked fine.  I guess this is a bug in 
>> the installer.  I'm posting this here just in case others encounter a 
>> similar problem, since I know that plenty of TeXers use aspell.
I had remembered something along these lines but thought that, since I 
had lived so far without CocoAspell, I could keep on doing so for the 
time being. Hence my "Oh well" but I should have been more specific 
about my complete inability to bash anyone or anything and/or my lack of 
courage to mess around with permissions.

Grateful and apologetic regards
------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list