[OS X TeX] Re: dvips problem [with addendum]

Bruno Voisin bvoisin at mac.com
Tue Jun 6 18:18:01 CEST 2006

Le 6 juin 06 à 17:51, Stephen Anderson a écrit :

> I'm really sorry to keep at it.  But these files are all in  
> (subdirectories of) these locations, like:
> /Users/sra/Library/texmf/fonts/tfm/AdobeGaramondPro/padr8r--base.tfm
> /Users/sra/Library/texmf/fonts/tfm/AdobeGaramondPro/padr8r--lcdfj.tfm
> /Users/sra/Library/texmf/fonts/tfm/AdobeGaramondPro/padr8r.tfm
> The map file entry for padr8r is
> padr8r--lcdfj AGaramondPro-RegularLCDFJ "" <AGaramondPro- 
> RegularLCDFJ.pfb
> padr8r--base AGaramondPro-Regular  
> "AutoEnc_vbofd7zvdbrujjjeweezwvbpcd ReEncodeFont" <[a_vbofd7.enc  
> <AGaramondPro-Regular.pfb

The encoding name AutoEnc_vbofd7zvdbrujjjeweezwvbpcd seems  
suspicious, but maybe it's legitimate.

> The following files are present:
> /Users/sra/Library/texmf/fonts/type1/AdobeGaramondPro/AGaramondPro- 
> Regular.pfb
> /Users/sra/Library/texmf/fonts/type1/AdobeGaramondPro/AGaramondPro- 
> RegularLCDFJ.pfb
> /Users/sra/Library/texmf/fonts/enc/lcdftools/a_vbofd7.enc
> But when I run dvips, I still get messages like this:
> This is dvips(k) 5.95b Copyright 2005 Radical Eye Software  
> (www.radicaleye.com)
> ' TeX output 2006.06.06:1718' -> Surmiran.ps
> kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 1 
> +437/600 --dpi 1037 padr8r--base
> mktexpk: don't know how to create bitmap font for padr8r--base.
> kpathsea: Appending font creation commands to missfont.log.
> dvips: Font padr8r--base not found, characters will be left blank.
>> Afterwards, run "sudo -H updmap-sys --enable Map  
>> <mapfilename>.map" where <mapfilename> is the name of your map file.
> I did that.  A couple of times, actually.  I tried disabling the  
> map and then re-enabling it.  But nothing seems to help.
> This is all so maddening, because everything about these fonts has  
> worked perfectly (on two separate machines with the same files) for  
> quite some time.
> Thanks again for your time and assistance.

I'm sorry, but I really can't help more (not enough time). Please  
turn to the OS X TeX list for more expert help.

The fact that padr8r--base isn't found seems to indicate your map  
file hasn't been taken into account. If it has, then you should see  
the padr8r entries inside /Library/teTeX/share/texmf.local/fonts/map/ 
dvips/updmap/psfonts.map, for example; and you should see you map  
file listed inside /Library/teTeX/share/texmf.local/web2c/updmap.cfg,  
without comment character #!.

The existence of a directory ~/Library/texmf/fonts/map/dvips/updmap/  
would be a bad sign, showing that updmap has again not been run in  
the proper mode. So would be the existence of a file ~/Library/texmf/ 

A good sign would be that "kpsewhich psfonts.map" returns the  
following output:

	$ kpsewhich psfonts.map

Something known to have caused problems in the past is the existence  
of a file ~/.MacOSX/environment.plist containing path settings, but I  
can't see how this could affect dvips given this file affects GUI  
applications only and not CLI utilities.

I'm sorry, but I really can't devote more time to this.

Bruno Voisin------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list