[OS X TeX] Assorted unix woes (slightly OT)

Alan Munn amunn at msu.edu
Mon Aug 28 01:24:15 CEST 2006

At 10:39 PM +0200 8/27/06, Peter Dyballa wrote:
>Am 27.08.2006 um 21:21 schrieb Alan Munn:
>>1. Cocoa aspell
>>I downloaded the new Intel version of Cocoa aspell and it seemed to 
>>have installed ok.  However, when I open the Spelling preference 
>>pane it says that the English dictionary failed to compile  because 
>>I don't have sufficient access privileges.   There is a vague note 
>>in the documentation about some users reporting problems if their 
>>default shell is tcsh (which is my case, but there is no further 
>>help on this.)
>The workaround: create an admin user with bash and re-install!

Actually this is only part of the problem (or maybe even unrelated.) 
I did as you suggested and still got the same problem.  It seems that 
cocoaAspell sets the user permissions of its directory to the the 
username of the UID 501 and the group permission to 501.  Since I was 
using a different admin account, when it tried to build the 
dictionaries, it couldn't.  When I changed the permissions to my user 
id and admin as the group, it worked fine.  I guess this is a bug in 
the installer.  I'm posting this here just in case others encounter a 
similar problem, since I know that plenty of TeXers use aspell.


Alan Munn                                                   amunn at msu.edu
Department of Linguistics                                   amunn at acm.org
and Germanic, Slavic, Asian and African Languages   Fax.  +1-517-432-2736
Michigan State University, East Lansing MI 48824    Tel.  +1-517-355-7491
------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list