[OS X TeX] OT-File ownership

Michael S. Hanson mshanson at wesleyan.edu
Fri Sep 30 01:17:23 CEST 2005

     I am reviving this thread in the hope that someone might be able  
to assist -- apologies in advance for the length;  I am near wit's  
end on this issue....


     My TeXShop documents (files that end in .tex) open in another  
application when double-clicked in the Finder.  (Not surprisingly,  
they also do not have the correct icon.)


     OS X 10.4.2 with latest security update (008).  TeXShop 2.0.3.


     I can change the "Open with:" settings in each individual file's  
"Get Info" window to TeXShop, but when I click on the "Change All..."  
button, the files all revert back to the other application.   
Currently, that application is TextEdit.  Previously it was BBEdit,  
and before that it was ScriptEditor.

     The problem arose after an "Erase and Install" of 10.4.  I had  
restored my user account with the Migration Tool from a second  
internal drive that had contained a cloned image of my primary  
internal drive with its previous 10.3.9 installation.  (It now  
contains a cloned backup of the current installation created with  


> On Sep 19, 2005, at 8:55 PM, Herbert Schulz wrote:
>> You might try the solution to really rebuild the Launch Services  
>> using the hint at <http://www.macosxhints.com/article.php? 
>> story=20031215144430486&query=rebuild+launch+services>.

     I issued the command:

sudo /System/Library/Frameworks/ApplicationServices.framework 
\Frameworks/LaunchServices.framework/Support/lsregister -kill -r -f - 
domain local -domain system -domain user

and then rebooted.  (This version of the command is in the comments;  
it just adds the -f flag to force the changes.)  No effect.

> On Sep 19, 2005, at 10:28 PM, Vince McGarry wrote:
>> ... throwing away com.apple.LaunchServices.plist appears to have  
>> done the trick.
     I've tried that, followed first by a logout and login, then by a  
reboot.  No effect.

> On Sep 19, 2005, at 8:55 PM, Herbert Schulz wrote:
>> I'm not sure this is the solution but you might try using  
>> RCDefaultApp, a Preference Pane that allows you to look at and  
>> change assignments.

     I have had RCDefaultApp version 1.3 installed on this Mac since  
before the 10.4 upgrade.  I am beginning to wonder if it is part of  
the problem rather than the solution.  I have been able to change --  
inadvertently -- which application opens .tex files by changing the  
application associated with the TEXT file type.  According to  
RCDefaultApp, when the "default" app is selected for this file type,  
the file type is associated with the UTI: com.apple.traditional-mac- 
plain-text.  And in that case the default app is TextEdit.   
Previously, BBEdit had been associated with the TEXT file type --  
which I changed by hand.  Previously ScriptEditor was associated with  
this file type;  I think that was the first mis-association following  
the upgrade to 10.4.

     All of my .tex files created with TeXShop have the creator TeXs  
and the file type TEXT.  As mentioned above, when I manually set the  
"Open with:" application from the "Get Info" window in the Finder to  
TeXShop, the setting sticks.  But when I click on the "Change All..."  
button, the file association (and icon) gets set to the application  
that is listed by RCDefaultApp as the default application for the  
TEXT file type.

     RCDefaultApp reports that the .tex and .TEX extensions are  
associated with TeXShop.  However, that is not the case in the  
Finder.  TeXShop does not have a UTI listed with RCDefaultApp, as far  
as I can tell.

     Any further suggestions to resolve this problem would be greatly  
appreciated.  Even an AppleScript or Automator workflow to force  
all .tex files to have their "Open with:" applications switched one- 
by-one to TeXShop would be great -- I tried unsuccessfully to figure  
out how to create such a workflow myself, and I am not looking  
forward to potentially changing the hundreds* of TeXShop files that  
are scattered across my hard drive individually.

                                         -- Mike

(*) When I used Spotlight to search for files of kind "tex" -- it  
doesn't appear to be possible to search for files with the kind  
TeXShop on my Mac (although lots of other apps appeared in the kind  
list) -- over 4300 files showed up.  However, the search results  
included AppleScripts, BBEdit files, plain text files, etc.  Clearly  
the file types are pretty hosed (a technical term).  When I added  
Name Ends With "tex" to the search, the list narrowed to about 430  
files -- 95% of which are showing up as TextEdit files, with a few  
BBEdit and SubEthaEdit file owners thrown in.  I suspect there are  
more than those 430, as Spotlight only seems to index files after  
2002 for me, and I know I have documents (including TeX documents)  
from the late-1990s onward on this Mac.  But that's another (OT)  
problem for another time....
------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list