[OS X TeX] Aquamacs, AucTeX, and preview-latex

Cameron Hooper chooper at umich.edu
Sun Nov 27 20:14:49 CET 2005

On Nov 27, 2005, at 1:32 PM, Paulo Ferreira wrote:

> On 27/nov/2005, at 03:11, Cameron Hooper wrote:
>> Hi
>> I've having a look at auctex and am having trouble getting preview- 
>> latex to work. I'm using Aquamacs (0.9.6) and installed auctex  
>> using the package from http://yaced.sourceforge.net and installed  
>> to /Library/Application Support/Emacs as stated in Aquamacs Help.  
>> Visiting a latex file loads auctex, but I don't see any menu items  
>> for preview-latex. I tried typing C-c C-p C-d as suggested in the  
>> preview-latex manual, but emacs responds with C-c C-p is  
>> undefined. I tried adding
>> (load "preview-latex.el" nil t t)
>> to .emacs, but nothing changed. Any suggestions on what I'm doing  
>> wrong?
>> Cameron
> Sorry for asking basic questions:
> Did you install it  under   $HOME/Library/Application Support/Emacs  
> (where $HOME is your home directory) as recommended or to /Library/ 
> Application Support/Emacs  ?
> Did you look in the Commands menu (between the Tex and Help menus)?
> Greetings
> Paulo Ferreira

Hi Paulo

Thanks for taking the time to help me.

According to Aquamacs Help (at least in my version 0.9.6 which I  
believe is the latest non-beta), the recommended installation  
location is /Library/Application Support/Emacs not $HOME/Library/ 
Application Support/Emacs. Anyway, I tried the location you suggest,  
removed all code related to auctex and preview-latex in my .emacs and  
tried again. C-c C-p is still undefined. I have no Preview menu. I  
have nothing in the Command menu (for me between Latex and Ref menus)  
that seems to relate to preview-latex.

I added $HOME/Library/Application Support/Emacs/site-lisp/site- 
start.d to my load path and tried with and without loading preview- 
latex.el (and auctex.el).

No preview commands.

I removed the $HOME/Library/Application Support/Emacs load path and  
loaded $HOME/Emacs/site-start.d as described in my response to Pete.  
Hmmm, this no longer works: there is no Preview command. So I deleted  
everything the installer added to the earlier load path and restarted  
emacs. Now the Preview menu (between Tools and LaTeX) is back. I  
think there is a bug somewhere.

------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list